Jump to content

Screenshot crashes client [New info]


Recommended Posts

I used ctrl + print screen just a few hours ago and it was fine.

 

then get a "user already logged" message when I try to log back in

 

Normal for most MMO I have ever seen. Depending on how you were logged out or exited.

Link to post
Share on other sites

I used ctrl + print screen just a few hours ago and it was fine.

 

Hmm, I'll try that. I've just been using Print Screen by itself.

then get a "user already logged" message when I try to log back in

 

Normal for most MMO I have ever seen. Depending on how you were logged out or exited.

Yeah, it's because of that 10-second delay when you log out the normal way. If you crash, the server still requires that 10-second delay, plus there may be some additional time before the server realizes you're "logged out". Just have to wait it out a bit. When I got the "already logged in" error, I just immediately tried again and got in on the second attempt.

Link to post
Share on other sites

Posted this in another thread, and figured I should post here as well:

 

 

Looking through my Windows 10 (latest update, as far as I know) settings, under Settings -> Gaming, it shows that Win+Alt+PrtScrn will take a screenshot.

 

It gets saved automatically to This PC > Videos > Captures.

 

This is working for me.

Link to post
Share on other sites
  • 3 weeks later

Update with some new information, since using PrintScreen (or, honestly, any keybind I set to take a screenshot in Options) is still crashing my client.

 

Digging into the CoH folder, I discovered that the Screenshots folder is flagged "Read Only". I see how this could be causing a problem with trying to save a screenshot, and possibly contributing to the crashes. I unflagged it, but it keeps automatically reflagging itself as soon as I close the Properties window. Thus, I suspect some property of the parent window?

 

Indeed, the CoH folder itself is flagged Read Only. I unflagged that folder, and applied it to all subfolders. But it does the same thing - reflags to Read Only once I close the Properties window.

 

I'm still fairly new to Windows 10, having been a Mac user for 22 years prior to buying this Windows 10 gaming PC (from CyberpowerPC) a bit over a year ago. So I'm not sure what is causing this Read Only reflagging. Could it be my antivirus doing it? I use Avast.

Link to post
Share on other sites
  • 5 months later

The problem more or less stopped for me a few patches ago. The default screenshot functionality works now without crashing my client.

 

Nevertheless, I've switched to using the screenshot ability provided by my GeForce Experience software, because half the time the game's default screenshots are getting flagged by ... something ... that results in my not being able to edit them (like when I try to crop a screenshot to share). Well, I can edit them, but my computer refuses to save the edited file because it thinks it's malware or something.

Link to post
Share on other sites
On ‎5‎/‎28‎/‎2019 at 12:14 PM, RikOz said:

Update with some new information, since using PrintScreen (or, honestly, any keybind I set to take a screenshot in Options) is still crashing my client.

 

Digging into the CoH folder, I discovered that the Screenshots folder is flagged "Read Only". I see how this could be causing a problem with trying to save a screenshot, and possibly contributing to the crashes. I unflagged it, but it keeps automatically reflagging itself as soon as I close the Properties window. Thus, I suspect some property of the parent window?

 

Indeed, the CoH folder itself is flagged Read Only. I unflagged that folder, and applied it to all subfolders. But it does the same thing - reflags to Read Only once I close the Properties window.

 

I'm still fairly new to Windows 10, having been a Mac user for 22 years prior to buying this Windows 10 gaming PC (from CyberpowerPC) a bit over a year ago. So I'm not sure what is causing this Read Only reflagging. Could it be my antivirus doing it? I use Avast.

Where Exactly is the game installed to? There are a slew of parent folders that windows will protect and auto-label their child folders as read only.

OG Server: Pinnacle  <||>  Current Primary Server: Torchbearer  ||  Also found on the others if desired


Installing CoX:  Windows  ||  MacOS  ||  MacOS for M1  <||>  Migrating Data from an Older Installation


Clubs: Mid's Hero Designer  ||  PC Builders  ||  HC Wiki  ||  Jerk Hackers


Old Forums  <||>  Titan Network  <||>  The City Representative (Info site for all servers)  <||>  Heroica! (by @Shenanigunner)

 

Link to post
Share on other sites
3 hours ago, WanderingAries said:

Where Exactly is the game installed to? There are a slew of parent folders that windows will protect and auto-label their child folders as read only.

It was installed to my SSD (E: drive). Recently moved it to my C drive.

 

But as I mentioned in my last post, the screenshot issue has been fixed; at least it's no longer giving me any issues.

Link to post
Share on other sites

Huh, must not have seen more to the scroll bar when I was reading.

OG Server: Pinnacle  <||>  Current Primary Server: Torchbearer  ||  Also found on the others if desired


Installing CoX:  Windows  ||  MacOS  ||  MacOS for M1  <||>  Migrating Data from an Older Installation


Clubs: Mid's Hero Designer  ||  PC Builders  ||  HC Wiki  ||  Jerk Hackers


Old Forums  <||>  Titan Network  <||>  The City Representative (Info site for all servers)  <||>  Heroica! (by @Shenanigunner)

 

Link to post
Share on other sites
  • 8 months later

This is now happening to me as of today.  It was working fine yesterday.

 

My screenshot folder is marked as Read Only and that can't be changed even though I have full permissions.  Does anyone know whether that's normal?  Don't want to pursue a red herring if others' screenshot folders are marked RO but they don't have the crash.

 

I've tried revalidating all files, even a complete reboot of the PC, to no avail.  Client crashes with no error message.

 

P.S. The problem with using another screenshot utility is that I'd expect it would include the game UI, which I don't want.

 

P.P.S. Just had a chat in the Help channel, and I was told I'm the second person reporting this today. Also, this helpful person (Water of Mars) who can do screenshots without a crash checked their folder and it's marked as Read Only, so that's apparently not related to the problem.

Edited by Cinnder
Link to post
Share on other sites

I figured out what was causing it on my end: AVG.  Must have been an update on Monday that made it suddenly not trust CoX.

 

Added the game folder to the exception list in AVG and screenshots work again.

  • Thanks 3
Link to post
Share on other sites
  • 4 months later
On 7/14/2020 at 10:11 PM, Cinnder said:

I figured out what was causing it on my end: AVG.  Must have been an update on Monday that made it suddenly not trust CoX.

 

Added the game folder to the exception list in AVG and screenshots work again.

Thank you, thank you, thank you!!! This was apparently causing my issue as well. I can once again take screenshots!

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
×
×
  • Create New...