Jump to content
GM Dredd

Graphics Card / GPU Survey

Recommended Posts

Hey folks,

 

If you could please reply to this topic with your graphics card / gpu info and your experience with the game it will help us with diagnosis of problems and getting newcomers on-board, thank you!

To get your OS Version info - Mac users look in the Apple Menu for About This Mac, Windows users can open a run box (Windows Key + R) and enter Winver and click OK.

 

Needed info:

Manufacturer:

Model:

Operating System and version:

Does the game load (and error you get if not):

 

Optional info you like:

Driver Version:

Monitor Resolution:

Multi-monitor?:

Graphics Preset Used:

Overall experience (any stuttering, glitching, etc or smooth sailing):

Any steps taken to resolve issues you encountered (both those that worked and those that didn't):

 

Thank you again for taking the time to help your fellow heroes and villains!


Share this post


Link to post
Share on other sites

Manufacturer:  graphic card NVIDIA

Model:  GeForce GTX 760, version 418.91

Operating System and version:  Win 10, version 1803

Does the game load (and error you get if not):  game is loading well & playing great

 

 

Share this post


Link to post
Share on other sites

Manufacturer:  Nvidia

Model: geforce GT 620

Operating System and version: Win 7

 

i do get a message about my video drivers at the login screen... everything works fine. i go windowed, and then maximize the window (easier for switching to a browser, where i listen to music).

 

 

Share this post


Link to post
Share on other sites

Manufacturer: Nvidia

Model:GTX 970

Operating System and version: Windows 10

Does the game load (and error you get if not): Runs and no errors

Optional info you like:

Driver Version:

Monitor Resolution: 1920x1080

Multi-monitor?: Just one

Graphics Preset Used: Custom - Ultra with a couple changed AA settings, also running ReShade

Overall experience (any stuttering, glitching, etc or smooth sailing): Smooth Jelly

Any steps taken to resolve issues you encountered (both those that worked and those that didn't): No issues

Share this post


Link to post
Share on other sites

Needed info:

Manufacturer: AMD Radeon

Model: RX 580 Series

Operating System and version: Win 10 build 1803

Does the game load (and error you get if not): Yes

 

Optional info you like:

Driver Version: 19.3.1

Monitor Resolution: 1920 x 1080

Multi-monitor?: no

Graphics Preset Used: in game graphics set to insane

Overall experience (any stuttering, glitching, etc or smooth sailing): Absolutly smooth

Any steps taken to resolve issues you encountered (both those that worked and those that didn't): Did not have any problems.

Share this post


Link to post
Share on other sites

Manufacturer: Nvidia

Model: GTX GeForce GTX 1660 Ti

Operating System and version: Windows 10 Pro (1809)

Does the game load (and error you get if not): No Issues Client Side

 

 

Driver Version: 430.39 Release Date: 04/23/2019

Monitor Resolution: 1920 x 1080

Multi-monitor?: Yes

Graphics Preset Used: Ultra

Overall experience (any stuttering, glitching, etc or smooth sailing): None Client Side

Any steps taken to resolve issues you encountered (both those that worked and those that didn't):

No steps taken

Share this post


Link to post
Share on other sites

Manufacturer: Nvidia

Model: GTX 1080

OS: Windows 8

Does the game load: Runs with no errors

Monitor resolution: 1920x1080

Multi-monitor: No

Graphics Preset used: Ultra with particles turned down to about 10,000

Overall experience: Better than ever

Share this post


Link to post
Share on other sites

Manufacturer: EVGA NVidia

Model: GeForce 1070

Operating System and version: Windows 10 version 1803

Does the game load (and error you get if not): Yes

 

Optional info you like:

Driver Version: 391.25

Monitor Resolution: 1920 x1080

Multi-monitor?: No

Graphics Preset Used: Default

Overall experience (any stuttering, glitching, etc or smooth sailing): Pretty good so far

Any steps taken to resolve issues you encountered (both those that worked and those that didn't):

 

Share this post


Link to post
Share on other sites

Manufacturer: MSi

Model: Nvidia 1660 Ti

Operating System and version: Win 10: Ver 1803

Does the game load (and error you get if not): Runs like a dream.

 

Optional info you like:

Monitor Resolution: 1920x1080p

Multi-monitor?: Not at the moment.

Graphics Preset Used: Custom Ultra with every setting at max

Overall experience (any stuttering, glitching, etc or smooth sailing): As is above: Runs like a dream.


Because I am hard you will not like me. But more you hate me, the more you will learn. I am hard but I am fair...

~Gny. Sgt. Heartman, Full Metal Jacket

 

I am the 'Slow Moving Madness'. I am Wandering Mania.

Share this post


Link to post
Share on other sites

Manufacturer: Nvidia

Model: Gtx 1050 ti

Operating System and version: Window 10 version 1803

Does the game load (and error you get if not): Run's perfectly!!!!

 

Monitor resolution: 1920x1080

Multi-monitor: No

Graphics Preset used: Ultra

Overall experience: Great!!!!

Share this post


Link to post
Share on other sites

Hey folks,

 

If you could please reply to this topic with your graphics card / gpu info and your experience with the game it will help us with diagnosis of problems and getting newcomers on-board, thank you!

To get your OS Version info - Mac users look in the Apple Menu for About This Mac, Windows users can open a run box (Windows Key + R) and enter Winver and click OK.

 

Needed info:

Manufacturer: NVIDIA

Model: 2080

Operating System and version: Windows 10 (1809)

Does the game load (and error you get if not): Yes

 

Optional info you like:

Driver Version: 430.39

Monitor Resolution: 2560x1440

Multi-monitor?: No

Graphics Preset Used: Max

Overall experience (any stuttering, glitching, etc or smooth sailing): smooth sailing if the Mapserver allows it

Any steps taken to resolve issues you encountered (both those that worked and those that didn't):

 

Thank you again for taking the time to help your fellow heroes and villains!

Share this post


Link to post
Share on other sites

Manufacturer: Nvidia

Model: Gtx 1050 (laptop)

Operating System and version: Window 10 64 bits

Does the game load (and error you get if not): The game runs perfectly although there is always an error message saying that the drivers for my Intel HD Graphics 630 are out of date. No idea my laptop had two cards.                 

 

Monitor resolution: 1920x1080

Multi-monitor: No

Graphics Preset used: Ultra

Overall experience: No problem so far.

Share this post


Link to post
Share on other sites

Needed info:

Manufacturer: Sapphire

Model: Vapor-X R9 290 4GB

Operating System and version: Windows 10 Home

Does the game load (and error you get if not): Yep!

 

Optional info you like:

Driver Version: Radeon 19.4.3

Monitor Resolution: 1920x1080

Multi-monitor?: No

Graphics Preset Used: Custom - Ultra with lower shadows and no SSAO etc.

Overall experience (any stuttering, glitching, etc or smooth sailing): Smooth for the most part even around large groups of players, any rubber-banding is network related not graphics.

Share this post


Link to post
Share on other sites

Manufacturer:

Model: NVIDIA GeForce GTX 1070

Operating System and version: Windows 10 Home, Version 1803

Does the game load (and error you get if not): Yup!

 

Optional info you like:

Driver Version: 25.21.14.1735

Monitor Resolution: 1920 x 1080

Multi-monitor?: Yes

Graphics Preset Used:Ultra

Overall experience (any stuttering, glitching, etc or smooth sailing): Smooth Sailing

Any steps taken to resolve issues you encountered: N/A

Share this post


Link to post
Share on other sites

Needed info:

Manufacturer:

Model: EVGA GeForce GTX 2070

Operating System and version: Win10Pro

Does the game load (and error you get if not): Yes

 

Driver Version: 25.21.14.2531

Monitor Resolution: 3440x1440 @ 120 Hz

Multi-monitor?: No.

Graphics Preset Used: Ultra

Overall experience (any stuttering, glitching, etc or smooth sailing): Smooth, except for the troubleshooting below.

Any steps taken to resolve issues you encountered (both those that worked and those that didn't):

 

When hitting highly populated areas, immediate judder and lag occurred. This was clientside, not serverside. Going to Options > Windows > X Display Buffs and enabling Hide Buffs and Don't update Buffs in the three sections resolved the issue.

Share this post


Link to post
Share on other sites

Manufacturer:

Model: Asus Strix rtx 2070, I7 - 8700, 32MB Ram

Operating System and version: Windows 10 build 1809

Does the game load (and error you get if not): game loads with no issue

 

Optional info you like:

Driver Version: geforce 430.39

Monitor Resolution:  1920 x 1080

Multi-monitor?: 2

Graphics Preset Used: Ultra

Overall experience (any stuttering, glitching, etc or smooth sailing): no video or loading issues

Any steps taken to resolve issues you encountered (both those that worked and those that didn't):

Share this post


Link to post
Share on other sites

Needed info:

Manufacturer:Nvidia

Model:gtx 1080

Operating System and version:windows 10 latest update

Does the game load (and error you get if not):Yes

 

Optional info you like:

Driver Version:425.31

Monitor Resolution:1080p

Multi-monitor?: Yes

Graphics Preset Used:Custom

Overall experience (any stuttering, glitching, etc or smooth sailing): For some reason at first i was fine, my brother has the same pc as me except for a 1070ti instead of a 1080, i started to not be able to get more than 20 fps, most of the time it was 10

when i was on the ultra preset, i had to lower most shadows settings to minimum and AO, bloom off, depth of field off, and now im at a stable 60. I mentioned my brother specs because he is in ultra and getting 90fps in the same places i was getting 10.

 

 

 

Share this post


Link to post
Share on other sites

Needed info:

Manufacturer: Zotac

Model: RTX 2080Ti AMP

Operating System and version: Win10 Pro 1803

Does the game load (and error you get if not): Works just fine.

 

Optional info you like:

Driver Version: 416.94

Monitor Resolution: 3840x2160

Multi-monitor?: No

Graphics Preset Used:Ultra

Overall experience (any stuttering, glitching, etc or smooth sailing):smooth sailing!

Share this post


Link to post
Share on other sites

Needed info:

Manufacturer: AMD (ASUS reference card)

Model: Fury X

Operating System and version: Windows 10 (1803)

Does the game load (and error you get if not): Yes

 

Optional info you like:

Driver Version: 19.2.2 Radeon

Monitor Resolution: 2560x1080

Multi-monitor?: No

Graphics Preset Used: Custom (Ultra + FSAA turned to 8x.), both windowed mode and fullscreen

Overall experience: smooth sailing, though alt-tabbing makes the game lag a bit when tabbing in (in fullscreen). This was the case in the OG as well, I suspect an issue with DX. Windowed mode fixes this.

Share this post


Link to post
Share on other sites

Manufacturer: Intel

Model: HD 3000 (integrated graphics toaster!)

Operating System and version: windows 7

Does the game load (and error you get if not): Yes, it's slow in populated areas but it runs.

 

Optional info you like:

Driver Version: The 'latest' drivers are from 2015, they still run.  My toaster can still run warframe currently, for example, but the integrated chip

isn't optimized for DX 10, so loading takes forever and I can't really do multiplayer anymore.

Monitor Resolution: windowed 800x600

Share this post


Link to post
Share on other sites

Manufacturer: NVIDIA

Model: 670

Operating System and version: Win7

Does the game load (and error you get if not): Loads fine, no errors.

 

Optional info you like:

Driver Version:

Monitor Resolution: 2560 x 1600

Multi-monitor?: No

Graphics Preset Used: Ultra and also Low

Overall experience (any stuttering, glitching, etc or smooth sailing):

  - Runs smoothly on Ultra, only a few periods of busy action where fps drops, but this old card overheats after about half an hour of play.

Any steps taken to resolve issues you encountered (both those that worked and those that didn't):

  - Reset graphics settings to minimum, now can run for about an hour before giving up the ghost.

 

Will be replacing with something modern in a week or so.

 

Share this post


Link to post
Share on other sites

Manufacturer: NVidia

Model: GTX 1050Ti

Operating System and version: Windows 10 (x64) 1809

Does the game load: Yup

 

Driver Version: 430.39

Multi-monitor?: Yes - 2

Monitor Resolution: 1) 1920x1080 60Hz / 2) 1680x1050

Graphics Preset Used: Ultra

Overall experience (any stuttering, glitching, etc or smooth sailing): Everything runs perfectly :)


@DBeaver - Saving Paragon City since 2005

Share this post


Link to post
Share on other sites

Manufacturer:Gigabyte/Nvidia

Model:GTX 1080

Operating System and version:Windows 10 ver 1809

Does the game load (and error you get if not):Yes

 

Optional info you like:

Driver Version:430.39

Monitor Resolution:1080p

Multi-monitor?:Yes

Graphics Preset Used:Custom

Overall experience (any stuttering, glitching, etc or smooth sailing):Stuttering due to server lag

Any steps taken to resolve issues you encountered (both those that worked and those that didn't):Not needed, it is server related


Curse%20logo.JPG Flinty.pngFlint Eastwood

Share this post


Link to post
Share on other sites

Manufacturer: Nvidia

Model: RTX 2080Ti

Operating System and version: Windows 10, version 1803

Does the game load (and error you get if not): Yes

 

Driver Version: 430.39

Monitor Resolution: 3440 x 1440

Multi-monitor?: No

Graphics Preset Used: Custom. No matter what the game will only use ~20% of my GPU power so I can't have more than low ultra settings.

Overall experience (any stuttering, glitching, etc or smooth sailing): FOV other than automatic creates a TON Of artifacts.

Any steps taken to resolve issues you encountered (both those that worked and those that didn't): FOV on automatic, ultra settings no more than low... Otherwise runs great.

Share this post


Link to post
Share on other sites

Manufacturer: AMD

Model: RX570 4GB

Operating System and version: Win 10  1809

Does the game load (and error you get if not): Yup

 

Driver Version: 19.2.2

Monitor Resolution: 1920x1080

Multi-monitor?: No

Graphics Preset Used: Ultra and then some (all sliders to the max and everything I could crank up to 11)

Overall experience (any stuttering, glitching, etc or smooth sailing): Smooth except in crowded areas (FPS drops to 20-10)

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×
×
  • Create New...