Jump to content
GM Dredd

Graphics Card / GPU Survey

Recommended Posts

Manufacturer: AMD

Model: Radeon RX480, 8GB VRAM

Operating System and version: Windows 7 (SP1)

Does the game load (and error you get if not): Yes

 

Driver Version: 17.5.2

Monitor Resolution: 1920x1080

Multi-monitor?: No

Graphics Preset Used: Ultra

Overall experience (any stuttering, glitching, etc or smooth sailing): Smooth. High framerate.

Any steps taken to resolve issues you encountered (both those that worked and those that didn't): Worked fine without tinkering.

Share this post


Link to post
Share on other sites

Needed info:

Manufacturer: NVidia

Model: GTX 970 ME

Operating System and version: Windows 7 Professional N, Version 6.1 (Build 7601, Service Pack 1)

Does the game load (and error you get if not): Loads fine.

 

Optional info you like:

Driver Version: GeForce Game Ready Driver 397.31

Monitor Resolution: 1920x1080

Multi-monitor?: No

Graphics Preset Used: Not a preset, mostly high / very high settings with a few things (ambient occlusion, anisotropic filtering, anti-aliasing, particles) lower - AO and particles out of concern about my wimpy-ass Core i3 CPU.

Overall experience (any stuttering, glitching, etc or smooth sailing): Framerates vary between 30-ish and 60, either way playable

 

Share this post


Link to post
Share on other sites

Needed info:

Manufacturer: Nvidia

Model: GTX680

Operating System and version: Windows 10 Home

Does the game load (and error you get if not): Loads fine

 

Manufacturer: Nvidia

Model: GTX1080

Operating System and version: Windows 10 Enterprise

Does the game load (and error you get if not): Loads and runs fine.

 

Optional info you like:

Monitor Resolution: (windowed) 1920x1280

Multi-monitor?: Yes

Graphics Preset Used: Custom - Ultra with lower shadows and no SSAO etc.

Overall experience Other than server load issues (mapserve etc.) runs perfectly well.

Share this post


Link to post
Share on other sites

Manufacturer: MSI

Model: GeForce RTX 2080Ti Gaming X Trio

Operating System and version: Windows 10 Pro Build 1809

Does the game load (and error you get if not): Yes, and runs VERY well.

Monitor Resolution: 1920x1080

Multi-Monitor: Yes

In-Game Preset Used: Maxed

Share this post


Link to post
Share on other sites

Manufacturer: AMD

Model: Radeon RX 580

Operating System and version: Win 10 Home

Does the game load (and error you get if not): Game runs great on Ultra (Only issues are Mapserver issues)

Share this post


Link to post
Share on other sites

anufacturer:

Model: NVIDIA GeForce GTX 1070

Operating System and version: Windows 10 Pro (1803)

Does the game load (and error you get if not): No Issues

 

Optional info you like:

Driver Version: 25.21.14.1735

Monitor Resolution: 1920 x 1080

Multi-monitor?: Yes

Graphics Preset Used:Ultra

Overall experience (any stuttering, glitching, etc or smooth sailing): No Issues.

Any steps taken to resolve issues you encountered: N/A

Share this post


Link to post
Share on other sites

Manufacturer:  graphic card NVIDIA

Model:  GeForce GTX 1070, version 397.64

Operating System and version:  Win 7 64bit, Service Pack 1

Does the game load (and error you get if not):  Game loads fine, plays smoothly.

 

I'm playing at 2560x1440 with the Ultra preset everything runs great normally 60+ FPS open map and 120+ in instances.

Share this post


Link to post
Share on other sites

Needed info:

Manufacturer: Nvidia

Model: GTX 950

Operating System and version: Windows 10 Pro (1803)

Does the game load (and error you get if not): Game loads fine

 

Optional info you like:

Monitor Resolution: 1920x1080

Multi-monitor?: Yes

Share this post


Link to post
Share on other sites

Manufacturer:Nvidia

Model: 2080ti Founders Edition

Operating System and version: Win 10

Does the game load (and error you get if not):game loads just fine

Share this post


Link to post
Share on other sites

Needed info: 

Manufacturer:  Cyberpower PC

Model: PVP3020LQ

Operating System and version: Win 10 64 bit version 1803

Does the game load (and error you get if not):  Yes, unless the login server times out

 

Optional info you like:

 

CyberPowerPC Gamer Panzer Desktop Intel Core i7 32GB Memory NVIDIA GeForce GTX 1080 2TB Hard Drive 256GB NVMe PCIe SSD White

 

Video Card Driver Version:  430.39  WHQL

Monitor Resolution: 2K Asus 27"  2560 x 1440

Multi-monitor?: I don't run 2 clients at once, only 1.  But sometimes I use Chrome browser on a 2nd 27" Asus monitor

Graphics Preset Used: none

Overall experience (any stuttering, glitching, etc or smooth sailing):  Good framerates.  Lag at times, even with FIOS 100/100, and mapserver disconnects

Any steps taken to resolve issues you encountered (both those that worked and those that didn't):  Relog

Share this post


Link to post
Share on other sites

Mac Pro Tower (cylinder)

 

Manufacturer:AMD

Model:FirePro D300

Operating System and version: Mac OS 10.13.6 (High Sierra)

Does the game load (and error you get if not): The game has been loading just fine

 

Optional info you like:

 

Monitor Resolution:3840x2160

Multi-monitor?: No

 

Overall experience: Runs great

Share this post


Link to post
Share on other sites

Model: Nvidia  GeForce GTX 660

OS: Win 10 Home

Does the game load (and error you get if not): Loads fine

 

Optional info you like:

Monitor Resolution: 1440 * 900

Multi-monitor?: nope

Graphics Preset Used: custom mid-high settings

Overall experience (any stuttering, glitching, etc or smooth sailing):  Smooth Sailing

 

 

 

Share this post


Link to post
Share on other sites

Needed info:

Manufacturer: NVIDIA

Model: GeForce GTX 1070 Ti

Operating System and version: Windows 10 Pro

Does the game load (and error you get if not): Yup!

 

Optional info you like:

Driver Version: 430.39

Monitor Resolution: 1440p and 1080p

Multi-monitor?: Yes, two monitors

Graphics Preset Used: Ultra

Overall experience (any stuttering, glitching, etc or smooth sailing): Smooth sailing

Any steps taken to resolve issues you encountered (both those that worked and those that didn't): What issues?

Share this post


Link to post
Share on other sites

Manufacturer: MSI

Model: GTX 1080 Duke

Operating System and version: Win 10 v.1803

Does the game load (and error you get if not):Game loads and works with no issue.

 

Optional info you like:

Driver Version:

Monitor Resolution: 2560x1440p

Refresh Rate: 165hz

Multi-monitor?:No

Graphics Preset Used: Every Graphics option is turned to its highest.

Overall experience (any stuttering, glitching, etc or smooth sailing): Weird boxy visuals around objects/characters (Might need to adjust AA or something similar). Will run in full screen 2560x1440p, The ui is correct, however the Camera behind the character is drastically off centered. Unplayable resolution.

Any steps taken to resolve issues you encountered (both those that worked and those that didn't): Changed DPI to application controlled and turned of Occlusion and all is well now.

Share this post


Link to post
Share on other sites

Manufacturer: Intel

Model: Iris Graphics 540 

Operating System and version: Windows 10 Pro version 1803

Does the game load (and error you get if not): Yep, aside from server reboots it runs pretty well

 

Driver Version: 24.20.100.6299

Monitor Resolution: 2736 x 1824 (don't remember what I set it to in-game)

Multi-monitor?: Nope

Graphics Preset Used: Custom

Overall experience (any stuttering, glitching, etc or smooth sailing): Smooth

Any steps taken to resolve issues you encountered (both those that worked and those that didn't):

 

Share this post


Link to post
Share on other sites

Manufacturer: Nvidia

Model: GTX GeForce GTX 1050 Ti

Operating System and version: Windows 10

Does the game load (and error you get if not): No Issues Client Side

 

Monitor Resolution: 1920 x 1080

Multi-monitor?: no

Graphics Preset Used: Ultra

Overall experience (any stuttering, glitching, etc or smooth sailing): None Client Side

Share this post


Link to post
Share on other sites

Needed info:

Manufacturer:Nvidia

Model:GTX 1060 6GB

Operating System and version: Windows 10 Version 1803

Does the game load (and error you get if not): Games loads just fine.

 

Optional info you like:

Driver Version: 430.39

Monitor Resolution: 1920x1200

Multi-monitor?: No

Graphics Preset Used: Default

Share this post


Link to post
Share on other sites

Needed info:

Manufacturer: XFX

Model:  Radeon RX 480 4 gig DDR5

Operating System and version:                          Windows 10 Pro 64 bit

Does the game load (and error you get if not):          Yes  Loads perfectly

 

Optional info you like:     

Driver Version:                18.5.1 Adrenalin  (needs update I know)

Monitor Resolution:          1355 x 768 (cheap LED television)

Multi-monitor?:                No

Graphics Preset Used:      Ultra,  full AA 16x

 

Overall experience (any stuttering, glitching, etc or smooth sailing):      Smooth Sailing

 

Any steps taken to resolve issues you encountered (both those that worked and those that didn't):        all I had to do was set up the resolution and GUI sizes.

 

Share this post


Link to post
Share on other sites

Needed info

Manufacturer: NVIDIA

Model: GTX 980

Operating System and version: Windows 10 / 10.0.17134 Build 17134

Does the game load (and error you get if not): Loads perfectly!

 

Optional info you like:

Driver Version: 25.21.14.1917

Monitor Resolution: 1920x1080 @ 144hz or 3840 x 2160 @ 144hz, both work.

Multi-monitor?: Yes, 3

Graphics Preset Used: Ultra, advanced, everything wide open

Overall experience (any stuttering, glitching, etc or smooth sailing): None client-sided.

Any steps taken to resolve issues you encountered (both those that worked and those that didn't): None.

Share this post


Link to post
Share on other sites

Manufacturer: nvidia

Model: Geforce RTX 2070

Operating System and version: Windows 10 x64

Does the game load (and error you get if not): Game loads fine, no errors

 

Optional info you like:

Driver Version: 25.21.14.2531

Monitor Resolution: 1920x1080 (native)

Multi-monitor?:Yes, (3)

Graphics Preset Used: Everything Maxed, no vysnch

Overall experience (any stuttering, glitching, etc or smooth sailing): Everything works great, no hitches or stutters, no glitches, smooth sailing.

Any steps taken to resolve issues you encountered (both those that worked and those that didn't):

 

Share this post


Link to post
Share on other sites

Hey folks,

 

Needed info:

Manufacturer:AMD

Model: Radeon R7 200 Series

Operating System and version: Windows 10

Does the game load (and error you get if not): Yes

 

Optional info you like:

Driver Version: 19.4.1

Monitor Resolution:1366x768

Multi-monitor?: y

Graphics Preset Used:

Overall experience (any stuttering, glitching, etc or smooth sailing): smooth sailing

Any steps taken to resolve issues you encountered (both those that worked and those that didn't):

 

Share this post


Link to post
Share on other sites

Manufacturer: Nvidia

Model: GeForce 10 Series - GTX 1070Ti

Operating System and version: Win10

Does the game load (and error you get if not): Smooth sailing

 

Driver Version: 425.31

Monitor Resolution: 1920x1080 @ 144Hz

Multi-monitor?: No

Graphics Preset Used: Ultra preset with World detail and Character detail at 200%

Overall experience (any stuttering, glitching, etc or smooth sailing): No problems so far.

Any steps taken to resolve issues you encountered (both those that worked and those that didn't): Have not had the need to tweak around.

Share this post


Link to post
Share on other sites

Needed info:

Manufacturer: Asus ROG Strix Radeon

Model: RX 470 4GB

Operating System and version: Win 10 build 1803

Does the game load (and error you get if not): Yes

 

Optional info you like:

Driver Version: 18.5.1

Monitor Resolution: 1920 x 1080

Multi-monitor?: Yes

Graphics Preset Used: Ultra

Overall experience (any stuttering, glitching, etc or smooth sailing): Just the lag from server, otherwise very smooth. Last Sunday was the smoothest.

Any steps taken to resolve issues you encountered (both those that worked and those that didn't): No problems so far.

Share this post


Link to post
Share on other sites

EVGA

GTX 1070

Win 10

Yes

 

Monitor Res: 2560 x 1440

Multi Mon: No

Preset Ultra/Custom

Overall: Minor Lag due to server with many map server disconnects but I easily get 50+ FPS.

Share this post


Link to post
Share on other sites

Manufacturer: Nvidia

Model:2 gtx 1070 in sli

Operating System and version: windows 10

Does the game load (and error you get if not):yea

 

Optional info you like:

Driver Version:

Monitor Resolution:1920x1080

Multi-monitor?:3

Graphics Preset Used:ultra

 

 

Manufacturer:ati

Model:hd 7870

Operating System and version:osx mojave (hackintosh)

Does the game load (and error you get if not):yes

 

Optional info you like:

Driver Version:

Monitor Resolution: 1920x1080

Multi-monitor?: yes

Graphics Preset Used: ultra

 

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×
×
  • Create New...