Jump to content

Today, the editor...


Recommended Posts

Let's see...

 

Everytime I try to move an npc, it ends up moving another object or raises the floor up or ends up filling up the whole section.

 

Can't put things in the wall despite room clipping enabled.

 

Connecting a tech balcony next to another tech balcony that is connected to a wall is next to impossible in the air. My solution was to place the balconies on the floor connect them and then raise up with shift.

 

Flying into a wall or floor and getting stuck.

 

Oh and my favourite putting those rikti "forcefields" upside down and into ceiling. Moving it is such a pain, it just reverts back to it's original position or just a random position I have to put upside down again with alt+shift.

Link to post
Share on other sites
On 3/1/2020 at 2:40 AM, Dacy said:

So, as usual, today I got transported across the base (distance covered seems to relate to my orientation at time of teleport: if I am looking nearly straight down, I only go to the base floor just below me, but it I am facing higher up, I am likely to land much farther away. Typically it switches the object I am interacting with to something in my line of sight, instead, as well. 
 

-Dacy

Dacy - Have you tried /unbind leftdoubleclick? As far as I can tell this completely resolves the random transport through the base.

it’s to the point where it’s the very first step every time I fire up the editor.  Before F3 or anything else.

 

Hope it helps!

 

- EB

Edited by Easter Bunny
Link to post
Share on other sites

Oh wow, haven't tried that! That will work when I accidentally click twice, tho the editor often tps me without clicking, sometimes just with starting to turn something, but I will see if that helps that, too! Thanks!

 

-Dacy

Link to post
Share on other sites

We had this discussion on Discord, but for the record, I have found that if you are rotating things, especially and almost always if you are rotating on two different axes, first one way and then another, if you are set to anything above 5 degrees,  (and sometimes even then), you will see strange angles added to your process. It's annoying! Sometimes I find if I do the angles in a different order than the order which got screwy, sometimes it behaves better, but I haven't done enough experimentation to discover the conditions.

 

-Dacy

Link to post
Share on other sites

Okay but that doesnt' explain why these beacons, which are rotated on one axis, are so screwy, while the FF and Brickstown beacons, which are rotated exactly the same way, are not.  Or why those FF and Brickstown beacons became screwy when the base reloaded.  Also, after we had that conversation on the base builders global channel, I went in and replaced them with beacons rotated at 1-degree increments.  Same thing happened.  But only to those beacons.

 

So I can only conclude that I've somehow managed to cause a rift in spacetime in this spot.  One which will expand to warp my entire base, and then eventually the whole city.

Link to post
Share on other sites

My bad, I misremembered where I had the convo, too many places...! 🙂

 

I've had spots in a base that acted differently than others, I think it's yet another glitch in the matrix.

 

-Dacy

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
×
×
  • Create New...