Jump to content

Install and Troubleshooting Guide v2


Recommended Posts

9 hours ago, Tryna_Dugid said:

i’m running into the same issues as the poster above me! 32bit and safe mode run great.

 

the errors are: 

 

“the code execution cannot proceed because MSVCP140.dll was not found. Reinstalling the program may fix this problem.”

 

“the code execution cannot proceed because VCRUNTIME140.dll was not found. Reinstalling the program may fix this problem.”

HOW TO FIX MISSING msvcp140.dll AND vcruntime140.dll FILES!!!

Just go to this link and download the Visual C++ Redistributable for Visual Studio 2015. I did this and now the game starts!! https://www.microsoft.com/en-us/download/details.aspx?id=48145

Link to post
Share on other sites

I fixed my issue by the above solution! Thanks for the help.

 

...I have encountered a new problem, though! I swapped out my monitor, and now when i attempt to run Tequilla, it immediately closes. there aren’t any error codes, it just closes the application 

Link to post
Share on other sites
  • 2 weeks later
On 4/26/2019 at 5:12 PM, Silk said:

Updated to v3.

 

# How to fix City of Heroes issues with OpenGL on Intel video cards (GPUs)

 

Please note this procedure has been updated as of 16 May 2019 to reflect the change in Homecoming's file name. Further updates have been made to update more GPUs.

 

This process was created by the SCOTS team in order to allows you to create what is known as a driver shim. This is basically a way to force the Intel driver (which is the root of this issue, not City of Heroes at all) to work in compatibility mode for an older version of Windows. Usually this sort of thing is handled by the folks who made the driver or by a game's developers. Since we lack the latter here & Intel doesn't seem to care about OpenGL support, we're forced to do this ourselves instead. It may be worth attempting to run CoX in compatibility mode (Win7/8/8.1) first. That's not a universal solution but some report it does the trick and is much simpler. Ask how in one of the support channels on the Discords if you're unsure!

 

Please note as well this will not likely improve performance for folks who can already get into the game. This is generally intended for allowing those with the affected GPUs to launch the game at all or who experience crashes almost immediately to play. This is somewhat of a work in progress as to specific GPUs and such. Please bear with us. If you have feedback for this process, please be sure to let me (Nilt) or another SCOTS volunteer know.

 

List of Intel GPUs confirmed to operate well with this process:

 

    Intel HD 3000

    Intel HD 620

    Intel HD 630

 

 

I followed all the steps in the post and was able to get to the loading screen, but then got an "unexpected error" "the error occured in cityofheroes.exe at relitive address 0x578aad."

 

I am now adding the beta client to see if that will work

Link to post
Share on other sites
  • 1 month later

Just noting that I was having issues on my MacbookPro late last year (I think after an OS update...not Catalina though) after I had successfully gotten it working.  I haven't touched it until today because I don't use it to play normally since it's a work laptop, but I was trying to help my nephew get it working on his MB.  I had also since updated MacOS to Catalina.  In any case, I removed Island Rum and everything else.  I downloaded the latest Island Rum, ran it, let it install Wine and download the game files and it worked just fine.

Link to post
Share on other sites

I successfully installed Island Rum on my Mac (Catalina Version 10.15.4) and was able to run City of Heroes Homecoming for the past 3 days. However, today I tried to run it and this window popped up (see attached image).

 

I tried uninistalling and reinstalling Island Rum but the same window is popping up. What should I do?

Screen Shot 2020-03-26 at 9.48.43 PM.png

Link to post
Share on other sites

First off, click the close button (red) on the small window. What happens?

2) Are you running safe mode? It has been discontinued. You'll need to switch manifests and do a rescan to run 32bit or 64bit

3) Does Catalina still use wine?

Link to post
Share on other sites
10 hours ago, Six Six said:

First off, click the close button (red) on the small window. What happens?

2) Are you running safe mode? It has been discontinued. You'll need to switch manifests and do a rescan to run 32bit or 64bit

3) Does Catalina still use wine?

1. Nothing happens when I press the close button on the small window
2. I have been trying to run 64-bit
3. I am not sure if Catalina still uses wine. Is there a way for me to check?

Link to post
Share on other sites

IIRC, Catalina doesn't use wine anymore, so I'm even less qualified to help you.

Did you use the client installer specifically for Catalina? Check here in the forums for it. I remember they released a fixed one some time ago.

You can go on Discord and try to contact GM AmonRa or EgyptoNerd (same guy). He's the resident guru for the mac. He helped me get mine running. According to him, it's usually a case by case basis and not a one size fits all fix. So message him directly on Discord and he'll help. His hours are kinda hard to pin, though.

Link to post
Share on other sites
On 3/26/2020 at 10:21 PM, Telekhine said:

I successfully installed Island Rum on my Mac (Catalina Version 10.15.4) and was able to run City of Heroes Homecoming for the past 3 days. However, today I tried to run it and this window popped up (see attached image).

 

I tried uninistalling and reinstalling Island Rum but the same window is popping up. What should I do?

 

On 3/27/2020 at 11:20 AM, Telekhine said:

1. Nothing happens when I press the close button on the small window
2. I have been trying to run 64-bit
3. I am not sure if Catalina still uses wine. Is there a way for me to check?

 

I'm experiencing the same problems, as well.  It was working fine before I updated to Catalina 10.15.4, but now after I updated the Mac OS it isn't working.

 

As far as I know, Wine is still used to run CoH on Macs.  The process running is the called the wine64-preloader, and the menu bar shows the app calling itself Wine.

Link to post
Share on other sites
  • 3 weeks later

Windows 7.  'Open GL driver for your video card was not found.' 

 

My card?  680MX. 

 

It was working fine for a year.  Until it wasn't.  Been offline from HC for several weeks now.  But I thought I'd give the support forum a whirl.

 

Maybe my GPU is fried.  I've got green static on my screen.  But windows can run in safe mode and 'normal' mode with said green static.  (My Mac partition isn't having it.)   In which case is there a 'software' mode I can run CoH in for the time being whilst I upgrade to a newer machine?

 

If anyone has got a 'brain dead' easy fix.  I'm all ears.

 

Regards,

 

Azrael.

Link to post
Share on other sites

This is something that has almost certainly come up before, but time considerations have prevented looking through all eleven pages and involved search routines.  The situation is as follows:

 

It appears, after having followed the installation guidelines as closely as possible, that the game has been loaded, at least to some extent.  When double-clicking the "Homecoming" icon. the "Loading..." bar appears, then, after a few seconds, the screen goes white with black sidebars.  The cursor is a rotating wheel.  This lasts for a few seconds, then the situation cuts out and I'm back to a plain desktop with no activity.  Multiple attempts to launch result in a repeat of the above situation.

 

I would very much appreciate some insights as to what the problem is - I'm running Windows 10, do not have a hell of a lot of programs or apps jamming things up, and can only think that some type of code has been left out or is being blocked from operating.  If anyone has experience with this situation, an offer of guidance or advice would be much, much appreciated.

Link to post
Share on other sites
16 hours ago, Starfighter said:

This is something that has almost certainly come up before, but time considerations have prevented looking through all eleven pages and involved search routines.  The situation is as follows:

 

It appears, after having followed the installation guidelines as closely as possible, that the game has been loaded, at least to some extent.  When double-clicking the "Homecoming" icon. the "Loading..." bar appears, then, after a few seconds, the screen goes white with black sidebars.  The cursor is a rotating wheel.  This lasts for a few seconds, then the situation cuts out and I'm back to a plain desktop with no activity.  Multiple attempts to launch result in a repeat of the above situation.

 

I would very much appreciate some insights as to what the problem is - I'm running Windows 10, do not have a hell of a lot of programs or apps jamming things up, and can only think that some type of code has been left out or is being blocked from operating.  If anyone has experience with this situation, an offer of guidance or advice would be much, much appreciated.

 

Is the Microsoft Visual C++ 2015 Runtime installed?  I assume you have Tequila working if you can launch the game at least.

Homecoming: City of Heroes -- Want to play now? Get started here. - Got an issue?  File a Support ticket. - Enjoy helping others? Consider joining us as a GM.

Link to post
Share on other sites

Tahquitz, thank you for the advisory - I don't have the opportunity at the moment to check on the C++ situation (I wish Microsoft would start to sharpen up their work - maybe they can upgrade to a B- at some point), but will do so later today.  Hoping very much to see the gang on later today.

Edited by Starfighter
  • Thanks 1
Link to post
Share on other sites

Tahquitz: My apologies for continuing the irritation, but thought I should mention - followed the above link, downloaded Microsoft Visual C++ Runtime and installed.  Then attempted a launch, and ended up with the same results as before.

 

I don't know if attempting to play this is essentially a lost cause, but I'd really like to utilize all resources reasonably possible.  If there are any other steps that the Devs, Mods or other parties think might be productive, please do not hesitate to make suggestions.

 

All thanks again, and hoping real hard to see the reassembled gang online real soon.

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
×
×
  • Create New...