Jump to content
Silk

Install and Troubleshooting Guide v2

Recommended Posts

Posted (edited)
On 3/27/2020 at 1:21 AM, Telekhine said:

I successfully installed Island Rum on my Mac (Catalina Version 10.15.4) and was able to run City of Heroes Homecoming for the past 3 days. However, today I tried to run it and this window popped up (see attached image).

 

I tried uninistalling and reinstalling Island Rum but the same window is popping up. What should I do?

Screen Shot 2020-03-26 at 9.48.43 PM.png

Any resolution on this? Or should I call it quits and partition the computer to Windows using Bootcamp?

 

Keep in mind this not only a Catalina problem. I am running:

macOS Mojave: v 10.14.6

MacBook Pro (Retina, 15-inch, Mid 2014)

Processor 2.2 GHz Intel Core i7

Memory 16 GB 1600 MHz DDR3

Graphics Intel Iris Pro 1536 MB

Edited by RobRauff

Share this post


Link to post
Share on other sites
2 minutes ago, RobRauff said:

Any resolution on this? Or should I call it quits and partition the computer to Windows using Bootcamp?

I run Island Rum occasionally, to have it check for new files, but despite sometimes getting new stuff downloaded I have not yet seen any changes.  I still get the two windows, and Win just hanging out doing nothing.  I'm glad I have a spare Windows PC I can run Homecoming on, but I'd really rather run it on my Mac. 😞

Share this post


Link to post
Share on other sites
1 hour ago, mykethomas said:

I run Island Rum occasionally, to have it check for new files, but despite sometimes getting new stuff downloaded I have not yet seen any changes.  I still get the two windows, and Win just hanging out doing nothing.  I'm glad I have a spare Windows PC I can run Homecoming on, but I'd really rather run it on my Mac. 😞

Wish I had that option but I dont currently, still running into the infamous Two Windows. Maybe we can reach out to some Devs and see if they have a solution although I am guess not many of them boot it up on Mac. Such a shame because like two days ago it was running perfectly.

Share this post


Link to post
Share on other sites

When I have occasionally had a popup like that I just quit it (it should show up as a separate entry in the dock, usually called wine-preloader or similar). Once I've done that its usually fine, but it does sometimes mess up my wine profile, at which point I just delete the profile (~/.privatewine) and let it rebuild itself on startup.

Share this post


Link to post
Share on other sites
Posted (edited)
28 minutes ago, Ernesto said:

When I have occasionally had a popup like that I just quit it (it should show up as a separate entry in the dock, usually called wine-preloader or similar). Once I've done that its usually fine, but it does sometimes mess up my wine profile, at which point I just delete the profile (~/.privatewine) and let it rebuild itself on startup.

Do you think I need the CoH.app in the CoH folder or is that an outdated method? And if I need it where can I find it?

Edited by RobRauff

Share this post


Link to post
Share on other sites

Delete the CoH.app its only getting in the way. Island Rum needs to be in Applications so it has the correct permissions to run. If you are still having issues you may want to delete the old CoH folder and restart Island Rum and let it re-create it (but that will take a little time)

Share this post


Link to post
Share on other sites
1 hour ago, Ernesto said:

When I have occasionally had a popup like that I just quit it (it should show up as a separate entry in the dock, usually called wine-preloader or similar). Once I've done that its usually fine, but it does sometimes mess up my wine profile, at which point I just delete the profile (~/.privatewine) and let it rebuild itself on startup.

For me, the wine-preloader showedwith the CoH logo, and quitting it didn't solve the problem.  Nor did deleting my wine profile.  Now, I don't even get the two windows, wine just hangs there.

 

I guess I'm going to give deleting the entire thing a try, and have Island Rum download the game again.

Share this post


Link to post
Share on other sites
2 hours ago, mykethomas said:

For me, the wine-preloader showedwith the CoH logo, and quitting it didn't solve the problem.  Nor did deleting my wine profile.  Now, I don't even get the two windows, wine just hangs there.

 

I guess I'm going to give deleting the entire thing a try, and have Island Rum download the game again.

Same thing happend to me, just finished my 3rd full re-install no luck. I have no idea what to do at this point.

Share this post


Link to post
Share on other sites
Posted (edited)

Was playing CoH yesterday, but needed to reinstall Windows 10 Pro and CoH after building a new system, so i installed Tequila and CoH to the (new) D:/Games directory, ran all the patching, clicked Play and received a "The application was unable to start correctly (0xc000007b). Click OK to close the application." error message. Revalidating didn't help, nor did deleting tequila.XML and tequilalog.XML and revalidating again.

 

Edit 1: Set Tequila to run as administrator and now the error message is "The code execution cannot proceed because MSVCP140.dll was not found. Reinstalling the program may fix this problem."

Edit 2: Found the fix: "HOW TO FIX MISSINGmsvcp140.dll AND vcruntime140.dll FILES!!! Just go to this link and download the Visual C++ Redistributable for Visual Studio 2015. I did this and now the game starts!! https://www.microsoft.com/en-us/download/details.aspx?id=48145"

Edited by Nyx Nought Nothing
clarity and details

Share this post


Link to post
Share on other sites
2 hours ago, Nyx Nought Nothing said:

Was playing CoH yesterday, but needed to reinstall Windows 10 Pro and CoH after building a new system, so i installed Tequila and CoH to the (new) D:/Games directory, ran all the patching, clicked Play and received a "The application was unable to start correctly (0xc000007b). Click OK to close the application." error message. Revalidating didn't help, nor did deleting tequila.XML and tequilalog.XML and revalidating again.

 

Edit 1: Set Tequila to run as administrator and now the error message is "The code execution cannot proceed because MSVCP140.dll was not found. Reinstalling the program may fix this problem."

Edit 2: Found the fix: "HOW TO FIX MISSINGmsvcp140.dll AND vcruntime140.dll FILES!!! Just go to this link and download the Visual C++ Redistributable for Visual Studio 2015. I did this and now the game starts!! https://www.microsoft.com/en-us/download/details.aspx?id=48145"

Tequila uses .NET Framework, so if it's able to launch and patch the game, Tequila isn't the cause of errors in starting the game.  That message you received is because Visual C++ 2015 Runtime isn't installed in Windows 10 by default.  You got it right. 🙂

Share this post


Link to post
Share on other sites
On 4/30/2020 at 9:30 AM, RobRauff said:

Same thing happend to me, just finished my 3rd full re-install no luck. I have no idea what to do at this point.

I managed to fix the problem, finally.

 

It appears that wine-preloaded had crashed, and the process was never killed.  So it was still running in the background, and thus prevented running the game again.

 

I opened up Activity Monitor, and clicked on Process Name to sort the items by the name of the process.  I looked for wine-preloaded, and saw that one of them was in red, and marked as "(Not Responding)".  I clicked on that line, and then clicked the left-most button on the button toolbar (it looks like an x in a circle).  It asked me what I wanted to do, and I selected "Force Quit", which made it disappear.  After that, I ran Tequila, and was able to start CoH again.  Happy day!

Share this post


Link to post
Share on other sites
Posted (edited)

Thanks for the guide, Silk. I followed it to the letter after having no joy with downloading all of the files through Tequila: It would simply not download anything.

 

I'm having an issue now though, where after firing up Tequila, it goes through the verification process, but then tries to download files again. Is this normal? Because it just hangs on .pigg files, and never seems to progress.

 

They do seem to be the files that are in the homecoming folder though... could that be because I've renamed it from 'score'? All of the files it's trying to download are already in there.

Edited by Chequers

Share this post


Link to post
Share on other sites

Score and Homecoming folders are client-specific.  They're used to hold the changes specific to our service. 

 

The Score folder isn't used by us anymore, so it should be safe to delete.  The Homecoming folder holds .piggs specific to our client, so that should be left alone.  It's not a big deal or time to reinstall if it was deleted by accident. Tequila will re-download the contents and take a little longer to start is all.

Share this post


Link to post
Share on other sites

I am a Mac user and every response I see says that I need Island Rum version 082220191. However every time I click on the download link, my Island Rum shows up as Version 062620201. I just upgraded my OS to ensure that it was up to date enough. Any idea where I can download the most recent version of Island Rum?

Share this post


Link to post
Share on other sites
5 hours ago, Spencerunder said:

I am a Mac user and every response I see says that I need Island Rum version 082220191. However every time I click on the download link, my Island Rum shows up as Version 062620201. I just upgraded my OS to ensure that it was up to date enough. Any idea where I can download the most recent version of Island Rum?

That is the most recent version.

 

08 22 2019 1 <-- Version in forum guides.

06 26 2020 1 <-- Version out now.

 

The first eight digits are a release date.

Share this post


Link to post
Share on other sites

Awesome. Thank you for the quick response. I’m still having a problem where it looks like everything is installed correctly, but when I click play it won’t load CoH. It will load for a couple minutes and then the check mark will just disappear without loading the game. I’ve tried deleting that hidden wine folder and completely uninstalling and reinstalling. Nothing has worked. If the issue isn’t the version then do you have any idea what it could be?

Share this post


Link to post
Share on other sites
On 7/13/2020 at 5:53 PM, Spencerunder said:

Awesome. Thank you for the quick response. I’m still having a problem where it looks like everything is installed correctly, but when I click play it won’t load CoH. It will load for a couple minutes and then the check mark will just disappear without loading the game. I’ve tried deleting that hidden wine folder and completely uninstalling and reinstalling. Nothing has worked. If the issue isn’t the version then do you have any idea what it could be?

I am having this same issue. You are not alone.

Share this post


Link to post
Share on other sites
On 7/13/2020 at 5:53 PM, Spencerunder said:

Awesome. Thank you for the quick response. I’m still having a problem where it looks like everything is installed correctly, but when I click play it won’t load CoH. It will load for a couple minutes and then the check mark will just disappear without loading the game. I’ve tried deleting that hidden wine folder and completely uninstalling and reinstalling. Nothing has worked. If the issue isn’t the version then do you have any idea what it could be?

So when I deleted and tried to redownload, island rum kept telling me "path not writable" and I followed the instructions to put homebrew in terminal. Then I downloaded the wineskin launcher and used island rum to play coh after that. It would only download the 32-bit version but I did it and it let me play that way. However, this also didn't work until I changed my settings to allow third party apps to run on my mac. This is in your System Preferences > Security & Privacy > General.

Share this post


Link to post
Share on other sites

Was cleaning out some old games and files from my SSD and saw COH and decided to try it after a fairly quick update the game loaded right up except it kept getting a  "wrong username/password" error when I know I was using the right info.

 

Quick fix was checking the forums here and I saw the game now has "live" servers and "beta" servers.  I had a couple character on Torchbearer back when I started this thread.  To get to my account I had to add this:

 

https://manifest.cohhc.gg/testing.xml

to the tequila options and saw that the "live" servers from back when I made this thread are now considered beta servers..lol

 

Anyways I thought any older peeps coming back and get the "wrong username/password" error they just need to check this out and see maybe if they can get there characters transferred to the new "live servers", I know they have an option to go from the new live to the old"beta" but not sure about the other way around...it's a little odd they didn't just automatically transfer everyone's accounts over regardless of if you were playing at the time or not.

Share this post


Link to post
Share on other sites
Posted (edited)

The Beta Servers were split off of the main manifest address of https://patch.savecoh.com/manifest.xml so new users and others who don't want to try the beta servers have less updates and downloads to patch.  The old manifest should still work.  BOTH manifests have links to the Homecoming Live service, so you only need one manifest whichever you prefer.

 

The other major change is that the Safe Mode client is no longer supported as of March 2020.  Safe Mode has been removed from the regular and beta manifests, going forward the new 32-bit and 64-bit clients are the only supported ones for Homecoming.

23 hours ago, Silk said:

Anyways I thought any older peeps coming back and get the "wrong username/password" error they just need to check this out and see maybe if they can get there characters transferred to the new "live servers", I know they have an option to go from the new live to the old"beta" but not sure about the other way around...it's a little odd they didn't just automatically transfer everyone's accounts over regardless of if you were playing at the time or not.


... If your account was made since Torchbearer was started, your toons on the live servers should be completely unchanged.  We added an automated Beta Account transfer tool that send a copy of your Live Server characters one-way only to the Beta Servers for tests and character respec experiments.  Your toons have be at least Level 2 before they'll be visible on the tool. 

 

Toons cannot copy back from Beta to Live.  That was not permitted with Paragon Studios, and we take the same stance... especially when we enable cheats on one pair of Beta servers.  If you don't use the Beta Account tool, you can log into Beta servers with your regular game account.  But if the Beta server is wiped none of your prior toons will be present.  (You can always copy them again with the same tool.)

Edited by GM Tahquitz

Share this post


Link to post
Share on other sites
Posted (edited)
21 hours ago, GM Tahquitz said:

The Beta Servers were split off of the main manifest address of https://patch.savecoh.com/manifest.xml so new users and others who don't want to try the beta servers have less updates and downloads to patch.  The old manifest should still work.  BOTH manifests have links to the Homecoming Live service, so you only need one manifest whichever you prefer.

 

The other major change is that the Safe Mode client is no longer supported as of March 2020.  Safe Mode has been removed from the regular and beta manifests, going forward the new 32-bit and 64-bit clients are the only supported ones for Homecoming.


... If your account was made since Torchbearer was started, your toons on the live servers should be completely unchanged.  We added an automated Beta Account transfer tool that send a copy of your Live Server characters one-way only to the Beta Servers for tests and character respec experiments.  Your toons have be at least Level 2 before they'll be visible on the tool. 

 

Toons cannot copy back from Beta to Live.  That was not permitted with Paragon Studios, and we take the same stance... especially when we enable cheats on one pair of Beta servers.  If you don't use the Beta Account tool, you can log into Beta servers with your regular game account.  But if the Beta server is wiped none of your prior toons will be present.  (You can always copy them again with the same tool.)

Hmm odd https://patch.savecoh.com/manifest.xml  was giving me the wrong username error but the https://manifest,cohhc,gg/testing.xml was working fine, after reading your post I tried the old savecoh manifest and it worked today. A bit odd as I tried more than once and I know I was using the same username/password.

 

Still I am quite impressed I was able to get back in with little hassle!

Edited by Silk

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×
×
  • Create New...