Jump to content

Installing the new Homecoming Launcher on a Mac


Recommended Posts

On 10/25/2020 at 12:00 AM, GM Manga said:

 

If anyone is getting this, the correct path is Z:\Applications\coh\Launcher

 

Even after disabling or uninstalling all my AV programs and such , I am still getting this message 

Screen Shot 2021-03-13 at 7.24.38 PM.png

Link to post
Share on other sites

I tried to install IslandRum

I already tried method 2 

As already shown in previous posts, it's not working 

Now, I tried now method one 

Here is what happens


First you see the green arrow and then it's gone

Then no more progress


Now, I am going to suggest that you guys look into WINE been a problem, or the wrapper or checking if needs to go through the process as shown in the video I will link from YouTube

That same process they used to get MidReborn to work on M1 chip Mac OS 

See if you need to do something similar to that 

As of right now, not procedure 1 nor procedure 2 is working on the MacBook Pro 13 inch  M1, Big Sur 
 

 

Screen Shot 2021-03-13 at 10.23.06 PM.png

Screen Shot 2021-03-13 at 10.22.34 PM.png

Link to post
Share on other sites
  • Game Master

Bear with me if you're having difficulties - there are a few instances where permissions issues have stopped the installation, and I'm still trying to work out a reliable way to overcome it.  Once I do that I'm going to attempt to build it right into the Installer.

 

I also work full time though (not for Homecoming - that would be awesome, but unfortunately it doesn't work that way), and sometimes two jobs in one week.  So if there are long gaps in my reponses or fixes, that's probably why.

  • Like 1
Link to post
Share on other sites
  • Game Master
17 hours ago, Voltak said:

 

Even after disabling or uninstalling all my AV programs and such , I am still getting this message 

Screen Shot 2021-03-13 at 7.24.38 PM.png

 

Anyone who is still seeing alerts similar to either of these, you have permission issues!  I have altered the Mac Installer so it now attempts to fix this permissions issue as well.  You can download it here: https://islandrum.eekstudio.com/mac-installer.zip

Link to post
Share on other sites

@Voltak

 

That video is for Catalina (didn't look for anything else) which has a different series of steps to boot, but yeah, try Manga's newest modifications to see if that helps as their's either a software conflict or permissions issue you're dealing with and without being in front of the device, it's hard to sort it out from my perspective/experience.

OG Server: Pinnacle  <||>  Current Primary Server: Torchbearer  ||  Also found on the others if desired


Installing CoX:  Windows  ||  MacOS  ||  MacOS for M1  <||>  Migrating Data from an Older Installation


Clubs: Mid's Hero Designer  ||  PC Builders  ||  HC Wiki  ||  Jerk Hackers


Old Forums  <||>  Titan Network  <||>  The City Representative (Info site for all servers)  <||>  Heroica! (by @Shenanigunner)

 

Link to post
Share on other sites
On 10/26/2020 at 10:54 PM, WanderingAries said:

 

Opened System Prefs -> Security & Priv -> General" <---I'd recommend triggering this automatically 

This is a Mac OS thing - would require a code signing cert and a bunch of work - work for a company that needs to do this and it is kind of a pain.

A quick change to instructions would help though, just use control + click to open the pkg file, then you have the option to "open" on that screen that pops up instead of having to go through the system security settings.

Link to post
Share on other sites
2 hours ago, DocMedico said:

This is a Mac OS thing - would require a code signing cert and a bunch of work - work for a company that needs to do this and it is kind of a pain.

A quick change to instructions would help though, just use control + click to open the pkg file, then you have the option to "open" on that screen that pops up instead of having to go through the system security settings.

 

Yeah, I think Manga's working on something to deal with it at this point.

OG Server: Pinnacle  <||>  Current Primary Server: Torchbearer  ||  Also found on the others if desired


Installing CoX:  Windows  ||  MacOS  ||  MacOS for M1  <||>  Migrating Data from an Older Installation


Clubs: Mid's Hero Designer  ||  PC Builders  ||  HC Wiki  ||  Jerk Hackers


Old Forums  <||>  Titan Network  <||>  The City Representative (Info site for all servers)  <||>  Heroica! (by @Shenanigunner)

 

Link to post
Share on other sites
On 3/15/2021 at 6:03 PM, WanderingAries said:

@Voltak

 

That video is for Catalina (didn't look for anything else) which has a different series of steps to boot, but yeah, try Manga's newest modifications to see if that helps as their's either a software conflict or permissions issue you're dealing with and without being in front of the device, it's hard to sort it out from my perspective/experience.

We solved everything

Manga and I discovered that it had everything to do with permissions 

 

Link to post
Share on other sites
  • 2 weeks later
On 3/16/2021 at 11:13 PM, Voltak said:

We solved everything

Manga and I discovered that it had everything to do with permissions 

 

Hi @Voltak and @GM Manga thank you so much for all of your hard work on this topic!
I am encountering the same issues that Voltak did and have followed all of the steps shown in this and other threads, to no avail.
I am on Catalina 10.15.7 and have changed everything I know how to change at a permissions level - including giving COH Launcher full disk access and changing the permissions settings for all package contents within the information pane.

Do you have any advice for a solution?

Screenshot 2021-03-26 at 15.42.47.png

Link to post
Share on other sites
8 hours ago, TheHumbleUnicorn said:

Hi @Voltak and @GM Manga thank you so much for all of your hard work on this topic!
I am encountering the same issues that Voltak did and have followed all of the steps shown in this and other threads, to no avail.
I am on Catalina 10.15.7 and have changed everything I know how to change at a permissions level - including giving COH Launcher full disk access and changing the permissions settings for all package contents within the information pane.

Do you have any advice for a solution?

Screenshot 2021-03-26 at 15.42.47.png

 

Unless you really DO have an AV on that system interfering, then that tends to be a permission. One key step seems to be to set the permissions, quit the installer, start the launcher. You may still get one more permission after hitting Play though. Restarting the Mac wouldn't hurt.

OG Server: Pinnacle  <||>  Current Primary Server: Torchbearer  ||  Also found on the others if desired


Installing CoX:  Windows  ||  MacOS  ||  MacOS for M1  <||>  Migrating Data from an Older Installation


Clubs: Mid's Hero Designer  ||  PC Builders  ||  HC Wiki  ||  Jerk Hackers


Old Forums  <||>  Titan Network  <||>  The City Representative (Info site for all servers)  <||>  Heroica! (by @Shenanigunner)

 

Link to post
Share on other sites

Hi @WanderingAries Thanks so much for your reply =D

 

I have no AV on the system aside from whatever native protections are in place.

 

I have set every permission possible - have added every file with a variation of the name Wine to my accessibility and full disk access permissions etc. as well as the launcher and restarted. I have changed privileges in the info panel for every file associated with the game but nothing seems to change the issue. Is there anywhere else you would recommend that I change permissions?

 

I am really curious how @Voltak got theirs working =P

 

 

Link to post
Share on other sites

@GM Manga, I'm confirming that I'm unable to get the Game to launch within a Mojave/Catalina/Big Sur VM with the New Launcher using that new file. IDK what changed, but the installations all follow the same route that Big Sur did at launch. I don't remember having to do most of this for Mojave/Catalina before. If I 'need' to, then I can try it Native, but I've got Island Rum on here too, so IDK where the potential interactions are. Overall, the remaining "issue" feels Wine related, but IDK how to test for that. Unlike before, it feels like the mini game window is actually being thrown (I swear I saw the window shoot into the corner once) off screen or Under the Menu Bar at the top.

 

I've been doing the following:

  1. Installed the Launcher
  2. Installed XQuartz
  3. Set Accessibility and Full Disk Access for Applications/Launch coh.app
  4. Ran launcher
  5. Wine Installer takes over
  6. Paying attention to the Dock, I see the Wine Installer, Wine Mono, and Wine Gecko running, but unsure of what's going on
  7. They sit seemingly idle after a minute, so I quit all three
    • Now this is part of an older installation guide I did before and it had no negative impact, but since the problem Feels like Wine, I'm not sure if I'm Causing it or not by doing this
  8. Ran Launcher again
  9. Get the EULA
  10. Launcher shows up in left corner as with Big Sur
  11. Drag to middle and clicked the install Live
  12. Game installs fine
  13. Signed into account with button
    • This launched a straight to background browser tab for Catalina/Big Sur
    • This did not launch the browser tab in Mojave even though it was already running in the background
  14. Ran game
  15. City of Heroes app shows in Dock, nothing on the screen anywhere (visible)
  16. Try the Toggle, nada
  17. Game producing No Sound either to indicate that it's actually running
  18. Have to Force quit the Game itself as it will not quit otherwise
Edited by WanderingAries

OG Server: Pinnacle  <||>  Current Primary Server: Torchbearer  ||  Also found on the others if desired


Installing CoX:  Windows  ||  MacOS  ||  MacOS for M1  <||>  Migrating Data from an Older Installation


Clubs: Mid's Hero Designer  ||  PC Builders  ||  HC Wiki  ||  Jerk Hackers


Old Forums  <||>  Titan Network  <||>  The City Representative (Info site for all servers)  <||>  Heroica! (by @Shenanigunner)

 

Link to post
Share on other sites
On 3/15/2021 at 8:22 PM, DocMedico said:

This is a Mac OS thing - would require a code signing cert and a bunch of work - work for a company that needs to do this and it is kind of a pain.

A quick change to instructions would help though, just use control + click to open the pkg file, then you have the option to "open" on that screen that pops up instead of having to go through the system security settings.

 

I need to check on this again as I've never tested this specifically

OG Server: Pinnacle  <||>  Current Primary Server: Torchbearer  ||  Also found on the others if desired


Installing CoX:  Windows  ||  MacOS  ||  MacOS for M1  <||>  Migrating Data from an Older Installation


Clubs: Mid's Hero Designer  ||  PC Builders  ||  HC Wiki  ||  Jerk Hackers


Old Forums  <||>  Titan Network  <||>  The City Representative (Info site for all servers)  <||>  Heroica! (by @Shenanigunner)

 

Link to post
Share on other sites
10 hours ago, GM Manga said:


1. Make sure you have the newest Mac Installer from https://islandrum.eekstudio.com/mac-installer.zip

 

2.  If you Get Info on your CoH folder, what do the permissions look like?

 

I'll have to check that 2nd bit out, but I was retesting from the latest build you put up. (I always start fresh and haven't been keeping an archive for once).

OG Server: Pinnacle  <||>  Current Primary Server: Torchbearer  ||  Also found on the others if desired


Installing CoX:  Windows  ||  MacOS  ||  MacOS for M1  <||>  Migrating Data from an Older Installation


Clubs: Mid's Hero Designer  ||  PC Builders  ||  HC Wiki  ||  Jerk Hackers


Old Forums  <||>  Titan Network  <||>  The City Representative (Info site for all servers)  <||>  Heroica! (by @Shenanigunner)

 

Link to post
Share on other sites

Interesting how "testing" environments can be worlds different from RL, but I wasn't expecting otherwise TBH. Also, I forgot to do anything like removing XQuartz in an effort to do a "clean" install if it matters. and IR is already installed as well. COH folder permissions are full RW across the board already. Overall, this was night and day from the VM testing, but beyond that, an improvement on the installation experience I had with the previous installer. Notably, there is no permission for "Full Disk Access" on any of the platforms.

 

Testing Mojave (Native)

Spoiler

 

  1. Installed no problems and had the following prompts, no real permissions set (same as before)
    • 2048065952_ScreenShot2021-03-27at8_04_08PM.png.1d602d55651756bf497278f9e49a4966.png
    • 278982096_ScreenShot2021-03-27at8_04_18PM.png.6accdfcd0d68e144038051aeee0eba64.png
    • 305734716_ScreenShot2021-03-27at8_04_30PM.png.77394c9da5f1fcc7e257dabb85765e6c.png
  2. I simply archived the older launcher and folder to a different drive, but the launcher (other than saying beta and not seeing newer info) looks the same as here again. Being pointed out here is the lack of logging in (top button) and the sync issue (bottom).
    • 1973793109_ScreenShot2021-03-27at8_06_01PM.thumb.png.c34d01d9ddf0757cc6c9236e513e50fd.png
  3. Successful game launch, no hiccups

 

 

 

Testing Catalina (Native)

Spoiler

 

  1. Installed no problems and had the following prompts, no real permissions set (new and improved!)
    • 2048065952_ScreenShot2021-03-27at8_04_08PM.png.1d602d55651756bf497278f9e49a4966.png
    • 278982096_ScreenShot2021-03-27at8_04_18PM.png.6accdfcd0d68e144038051aeee0eba64.png
    • 1432843054_ScreenShot2021-03-27at8_35_35PM.png.0a74792e0a01f92c7719573defe69a9c.png
  2. I simply archived the older launcher and folder to a different drive. The new one appears to be the same as it's supposed to be at a glance.
    • 1684874349_ScreenShot2021-03-27at8_42_23PM.thumb.png.3055439ffe0e62b138e23305087fe318.png
  3. Successful game launch, no hiccups

 

 

 

Testing Big Sur (Native/Hacked)

Spoiler

 

  1. Installed no problems and had the following prompts, no real permissions set (new and improved!)
    • 1451465915_ScreenShot2021-03-27at8_58_23PM.png.cbdf63a45b08243ce6141aeafe916561.png
    • 556865686_ScreenShot2021-03-27at8_58_36PM.png.8a50bf86413845ec9af66aa35f518e4a.png
    • 1942850441_ScreenShot2021-03-27at8_58_46PM.png.7495d0bae756045254d5c9b39b9a7e91.png
  2. I simply archived the older launcher and folder to a different drive. The new one appears to be the same as it's supposed to be at a glance.
    • 582286868_ScreenShot2021-03-27at9_07_04PM.thumb.png.ffbceea67e1dcbe5e7cb2da5c63a7a13.png
  3. Successful game launch, no hiccups

 

 

 

Testing Big Sur  on M1 (Native)

Spoiler

 

  1. Installed no problems and had the following prompts, no real permissions set (new and improved!)
    • 1730873055_ScreenShot2021-03-27at9_21_26PM.png.8265d3c67d27e09e2398c885f49129fb.png
    • 556865686_ScreenShot2021-03-27at8_58_36PM.png.8a50bf86413845ec9af66aa35f518e4a.png
    • 794135412_ScreenShot2021-03-27at9_21_51PM.png.32897ed34b210749100ed2cfbd7e7d7b.png
    • 1201830925_ScreenShot2021-03-27at9_23_29PM.png.3bef39f9d65ad864fb0e9e209947587e.png
    • 1492493886_ScreenShot2021-03-27at9_23_37PM.png.eb2e7f781bea37b51d2ce1d8b4df73c7.png
    • 1775575783_ScreenShot2021-03-27at9_24_05PM.png.e2294049d80ed0c471fefc6ce0473261.png
    • 1421663254_ScreenShot2021-03-27at9_24_18PM.png.e21bb03b5cf6ae627e7e8307e90da209.png
  2. I simply archived the older launcher and folder to a different drive. The new one appears to be the same as it's supposed to be at a glance.
    • 1988575002_ScreenShot2021-03-27at9_35_44PM.thumb.png.01b3e0653a6dda5be9aabed12bad8cb4.png
  3. Successful game launch, no hiccups beyond the need to toggle on first run

 

 

 

Edited by WanderingAries
Silly out of place images

OG Server: Pinnacle  <||>  Current Primary Server: Torchbearer  ||  Also found on the others if desired


Installing CoX:  Windows  ||  MacOS  ||  MacOS for M1  <||>  Migrating Data from an Older Installation


Clubs: Mid's Hero Designer  ||  PC Builders  ||  HC Wiki  ||  Jerk Hackers


Old Forums  <||>  Titan Network  <||>  The City Representative (Info site for all servers)  <||>  Heroica! (by @Shenanigunner)

 

Link to post
Share on other sites
On 3/26/2021 at 9:17 PM, TheHumbleUnicorn said:

Hi @WanderingAries Thanks so much for your reply =D

 

I have no AV on the system aside from whatever native protections are in place.

 

I have set every permission possible - have added every file with a variation of the name Wine to my accessibility and full disk access permissions etc. as well as the launcher and restarted. I have changed privileges in the info panel for every file associated with the game but nothing seems to change the issue. Is there anywhere else you would recommend that I change permissions?

 

I am really curious how @Voltak got theirs working =P

 

 

My issue had nothing to do with an AV 

It was purely how GM Manga wrote the script or the code in order to deal with the permissions

Manga then fixed it by dealing with the permissions 

He was going to deal with the launcher so that it addresses that

Manga knows what he's doing. 

Link to post
Share on other sites
4 minutes ago, Voltak said:

Manga knows what he's doing. 

 

Of this much, I've never had a doubt.

  • Like 1

OG Server: Pinnacle  <||>  Current Primary Server: Torchbearer  ||  Also found on the others if desired


Installing CoX:  Windows  ||  MacOS  ||  MacOS for M1  <||>  Migrating Data from an Older Installation


Clubs: Mid's Hero Designer  ||  PC Builders  ||  HC Wiki  ||  Jerk Hackers


Old Forums  <||>  Titan Network  <||>  The City Representative (Info site for all servers)  <||>  Heroica! (by @Shenanigunner)

 

Link to post
Share on other sites
On 3/27/2021 at 12:37 PM, GM Manga said:


1. Make sure you have the newest Mac Installer from https://islandrum.eekstudio.com/mac-installer.zip

 

2.  If you Get Info on your CoH folder, what do the permissions look like?

Hi Manga,

 

Thanks so much for your reply =D

 

The CoH folder had all permissions turned to Read & Write for all users and applied to all sub folders. I also updated my OS to Big Sur and experienced the same issues.

 

However, after much spelunking through the forums I discovered that another user bypassed this issue using bootcamp which I completely forgot existed.

 

Yesterday I was able to successfully partition my drive, install the windows client and log on to the game.

 

It is not the ideal solution but I found a way!

 

Thank you for all of your help and I will definitely try any new mac launcher builds that come out to see if I can get it running on my main partition.

 

So appreciative of what you guys do!

 

All my best =D

 

 

Link to post
Share on other sites
7 hours ago, TheHumbleUnicorn said:

Hi Manga,

 

Thanks so much for your reply =D

 

The CoH folder had all permissions turned to Read & Write for all users and applied to all sub folders. I also updated my OS to Big Sur and experienced the same issues.

 

However, after much spelunking through the forums I discovered that another user bypassed this issue using bootcamp which I completely forgot existed.

 

Yesterday I was able to successfully partition my drive, install the windows client and log on to the game.

 

It is not the ideal solution but I found a way!

 

Thank you for all of your help and I will definitely try any new mac launcher builds that come out to see if I can get it running on my main partition.

 

So appreciative of what you guys do!

 

All my best =D

 

 

 

That's great, unfortunately, the M1 Users won't have that option, so we're lurking just in case. 😕

OG Server: Pinnacle  <||>  Current Primary Server: Torchbearer  ||  Also found on the others if desired


Installing CoX:  Windows  ||  MacOS  ||  MacOS for M1  <||>  Migrating Data from an Older Installation


Clubs: Mid's Hero Designer  ||  PC Builders  ||  HC Wiki  ||  Jerk Hackers


Old Forums  <||>  Titan Network  <||>  The City Representative (Info site for all servers)  <||>  Heroica! (by @Shenanigunner)

 

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
×
×
  • Create New...