Jump to content
Sign in to follow this  
Number Six

General Feedback

Recommended Posts

This thread is for general feedback on the experience of installing / using the launcher. Bug reports should be created as separate threads to make tracking easier.

Share this post


Link to post
Share on other sites

Other than the previously mentioned "Firefox and Windows want to treat it like a virus," I'm going to say first impressions are good - though, as mentioned, I had to kill the install process and relaunch for it to create icons, but that's me. Everything else seemed to go fairly well.

 

Minor suggestions submitted in suggestions.


Primarily on Everlasting. Squid afficionado. Former creator of Copypastas. General smartalec.

Share this post


Link to post
Share on other sites

Positive:

The launcher "fixed" whatever that Windows 7 "takes forever to load the server's character list" problem!

 

Negative:

IDK if this is something I've just missed in past updates (haven't played most the year) or because of the launcher (doubtful), but the auto-login file doesn't work on Tequila anymore yet the file exists. I'm guessing there's been an update and it's been disabled in both launchers for consistency.

Edited by WanderingAries

OG Server: Pinnacle || Current Server: Torchbearer  || Also found on Indomitable & Excelsior (when needed)

Getting Started  ||  Dredd's Guide to Loading City of Heroes  ||  Install and Troubleshooting Guide v2

Mids' Reborn  ||  HeroStats  ||  Vidiot Maps  ||  QoL, Mods, etc  ||  Heroica! (by @Shenanigunner)

Old Forums  ||  Titan Network  ||  The City Representative (3rd party Info site for all servers)

Share this post


Link to post
Share on other sites
3 hours ago, WanderingAries said:

Positive:

The launcher "fixed" whatever that Windows 7 "takes forever to load the server's character list" problem!

 

Negative:

IDK if this is something I've just missed in past updates (haven't played most the year) or because of the launcher (doubtful), but the auto-login file doesn't work on Tequila anymore yet the file exists. I'm guessing there's been an update and it's been disabled in both launchers for consistency.

 Both of these are unrelated to the launcher. Details about both are listed on the Patch Notes for October 6th

Edited by GM Conviction

Share this post


Link to post
Share on other sites

Windows 10 didn't want me to install it. I overrode that and it installed in seconds.

 

I've had no issues whatsoever launching or playing the game.


I've finally returned home to Paragon City.

 

Thank you doesn't even come close to the gratitude I have for the Homecoming developers for resurrecting and continuing to improve my favorite video game.

Share this post


Link to post
Share on other sites

Just tried this. Launcher installs, but when you click "Accept" to actually start it, nothing happens.  There's a crash report that it generated. Where should I post it? 

 

Edited by Ramp72

Share this post


Link to post
Share on other sites
2 hours ago, Ramp72 said:

Just tried this. Launcher installs, but when you click "Accept" to actually start it, nothing happens.  There's a crash report that it generated. Where should I post it? 

 

Hi there. Thanks for testing. Please create a new topic in the main Homecoming Launcher forum here with the details about the bug report. I'd say to help visually distinguish it from topics like this one, start the subject line with [Bug Report]. This is not a requirement just a recommendation.

Share this post


Link to post
Share on other sites

Hello, this is general feedback:

 

First, I would like to say I really appreciate the volunteer team creating this new launcher. It feels like a legitimate game launcher now. Aesthetics aside (a point others have brought up about changing the launcher skins to match CoV/GR), every functionally important button is clearly labeled or easy to find. I downloaded all three items (game, pre-release, and beta) so effortlessly I actually reopened the launcher because I thought it didn't accept my command. So fast! My initial impressions were this: this launcher boots fast and gets me in the game very quickly, the login being tied to my forum handle feels secure, and the compatibility (aside from the annoying virus notifications, but I understand why) works seamlessly. 

 

Second, I tested this launcher using Windows 64bit and I did not notice any errors or hiccups, lag or bugs - literally the smoothest install and launch platform I have used since maybe Steam!

 

Third point - I also tested multiple account launching and it was perfect. I marked the multiple account box in the options ahead of time and tested how many accounts it would allow me to launch (I got to three and then figured that was enough!). 

 

Edited by Glacier Peak

Share this post


Link to post
Share on other sites
19 hours ago, GM Conviction said:

 Both of these are unrelated to the launcher. Details about both are listed on the Patch Notes for October 6th

I thought that might be why

  • Like 1

OG Server: Pinnacle || Current Server: Torchbearer  || Also found on Indomitable & Excelsior (when needed)

Getting Started  ||  Dredd's Guide to Loading City of Heroes  ||  Install and Troubleshooting Guide v2

Mids' Reborn  ||  HeroStats  ||  Vidiot Maps  ||  QoL, Mods, etc  ||  Heroica! (by @Shenanigunner)

Old Forums  ||  Titan Network  ||  The City Representative (3rd party Info site for all servers)

Share this post


Link to post
Share on other sites

The UI for this does not play well with UHD screen resolution.  The various settings are smashed together (see below).  The in-game UI is super, super tiny when logging in.  So small I am unable to use the mouse to select anything on it.  Game is also incredibly laggy for me using the launcher.  Via Tequila, it is perfectly fine.

 

spacer.png

Share this post


Link to post
Share on other sites

Feedback: Fast and easy as advertised for me. Running Win 7, 64bit. Not a fan of "allow multiple instances" being disabled by default, but that's a tiny issue. Seems to have imported all of my data successfully (costumes/Architect stuff/screenshots/settings/etc)

I've also noticed that the launcher (as well as Tequila) stay on screen, in front of the game, on launch. I realize this can be mitigated by checking the "exit on launch" parameter, but why not have it behave like Steam where it hides in the background when launching the game? I realize they're two different beasts with different functions (Steam wants to stay open to allow use of an overlay, "Hangover" just wants to launch the game), but, I think that would be a nice thing to put in, especially if you plan on expanding the scope and function of the launcher to do, well, anything else that might require it to be run while the game is running.

  • Like 1

Share this post


Link to post
Share on other sites

Figured I would add a new post instead of editing my older one for more visibility:

 

Just noticed this issue today - when I open up the HC Launcher my framerate drops from 165FPS to between 10-30FPS.

 

The exact steps are as follows:

1. On desktop, with no other programs running, monitor refresh rate displays I am sitting at 165 FPS

2. When I open the HC Launcher, it immediately drops to 30 FPS, then stabilizes at 10 FPS.

 

Is this an isolated incident or does anyone else notice significant framerate decline after opening the HC Launcher itself?

Share this post


Link to post
Share on other sites
5 hours ago, Glacier Peak said:

Figured I would add a new post instead of editing my older one for more visibility:

 

Just noticed this issue today - when I open up the HC Launcher my framerate drops from 165FPS to between 10-30FPS.

 

The exact steps are as follows:

1. On desktop, with no other programs running, monitor refresh rate displays I am sitting at 165 FPS

2. When I open the HC Launcher, it immediately drops to 30 FPS, then stabilizes at 10 FPS.

 

Is this an isolated incident or does anyone else notice significant framerate decline after opening the HC Launcher itself?

How are you getting your data? My best guess is that the app with the current priority (the app in the foreground) will determine the registered framerate based on its needs, but that's just speculation.


OG Server: Pinnacle || Current Server: Torchbearer  || Also found on Indomitable & Excelsior (when needed)

Getting Started  ||  Dredd's Guide to Loading City of Heroes  ||  Install and Troubleshooting Guide v2

Mids' Reborn  ||  HeroStats  ||  Vidiot Maps  ||  QoL, Mods, etc  ||  Heroica! (by @Shenanigunner)

Old Forums  ||  Titan Network  ||  The City Representative (3rd party Info site for all servers)

Share this post


Link to post
Share on other sites
1 hour ago, WanderingAries said:

How are you getting your data? My best guess is that the app with the current priority (the app in the foreground) will determine the registered framerate based on its needs, but that's just speculation.

Hi, I'm using my monitors built in frame rate counter. 

Share this post


Link to post
Share on other sites

The launcher is static and doesn’t draw any frames unless you’re interacting with it in some way and it needs to repaint. It uses Direct2D by default so if the GPU is sending less frames to the monitor it may be a video driver thing, possibly doing vsync when it does update. What if you also have something else running that is updating the screen more frequently?

 

You could try modifying the shortcut to start the launcher with a -nowdl flag. That will fall back to GDI rendering like any standard Windows application, though it may be slightly less responsive.

Share this post


Link to post
Share on other sites
13 hours ago, Number Six said:

The launcher is static and doesn’t draw any frames unless you’re interacting with it in some way and it needs to repaint. It uses Direct2D by default so if the GPU is sending less frames to the monitor it may be a video driver thing, possibly doing vsync when it does update. What if you also have something else running that is updating the screen more frequently?

 

You could try modifying the shortcut to start the launcher with a -nowdl flag. That will fall back to GDI rendering like any standard Windows application, though it may be slightly less responsive.

Interesting! I have g-sync enabled if that helps line up with your reasoning. I have had nothing else running (aside from the normal background apps that windows forces everyone to run) and those are taking up less than 4% of my CPU performance and 0% of my GPU performance. 

 

I do notice that when I click away from the screen and open something else (say google chrome) my frame rate returns to 165 FPS. If I click back to the launcher, it drops back to 10 FPS.

 

It isn't a big deal for gameplay, as once I click the server the frame rate drop disappears and I go back up to 165 FPS. It was just something unusual I wanted to annotate.

Edited by Glacier Peak
more info

Share this post


Link to post
Share on other sites
On 10/19/2020 at 12:59 PM, Glacier Peak said:

Figured I would add a new post instead of editing my older one for more visibility:

 

Just noticed this issue today - when I open up the HC Launcher my framerate drops from 165FPS to between 10-30FPS.

 

The exact steps are as follows:

1. On desktop, with no other programs running, monitor refresh rate displays I am sitting at 165 FPS

2. When I open the HC Launcher, it immediately drops to 30 FPS, then stabilizes at 10 FPS.

 

Is this an isolated incident or does anyone else notice significant framerate decline after opening the HC Launcher itself?

I had the same exact issue.

Share this post


Link to post
Share on other sites

I've been casually using it this week with no intentions to try to break things, just general playtesting to see if it serves its purpose. So far, the results are great. No issues, and the UI is very nice. A big upgrade over my Tequila experience. I also like the new file folder structure. It feels more intuitive to me.



PPM Information Guide                Survivability Tool                  Interface DoT Procs Guide

Time Manipulation Guide             Bopper Builds                      +HP/+Regen Proc Cheat Sheet

Movement Speed: Guide              Recharge Guide                   Base Empowerment: Temp Powers


Bopper's Tools & Formulas           RubyRed's API Tool              Mids' Reborn                       

Share this post


Link to post
Share on other sites

Launcher works fine except each time I drag my mouse on it it becomes dark and only shows what the mouse is directly touching. I'm operating on Win 7 family edition 64b

Share this post


Link to post
Share on other sites

It ports all the stuff from my Tequila folder ok, Then when installing the rest I get this prompt that says "Could not load launcher bootstrap package. This may indicate an internet connectivity issue."

 

Any ideas? I did disable my anti virus for the install as well.

Edited by grazerlor

Share this post


Link to post
Share on other sites

hey @Number Six Let me know if this is a bug I should report (I feel like it's more likely some setup incompatibility).

 

I've been having weird stuff going on with my windows and scales since I swapped over to the HC launcher.

 

image.png.af90ac7fdcb9e328c277003f606ead5d.png

 

Particularly, for some reason all my text I type is out of alignment (above the line).

 

Also, all of my pop-up windows such as when I click on a Contact, all show up down and to the right of center instead of dead-center.  This also affected other windows like my Compass being off to the right, but most windows were corrected by saving window settings to file again.  But the pop-ups continue to default South East of correct on any new characters.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×
×
  • Create New...