Jump to content

Random glitches prevent movement


Recommended Posts

For the last three or four days I'm having a strange glitch (I even asked in Help in game and I've saw two other players complaining about it after I asked, but I read at least the first 7 pages of this forum and I've found nothing about it).


Bear in mind I'm playing extensively with a particular character during this time (Arachnos Widow, now currently at 25) and I don't know if this bug is related only to that alt. I'll play with another alt today and report the problem in this thread if this also occurs. The bug has manifested while playing solo and while in a team.


The bug is temporary, but here are its effects:

  • W key stops working for forward movement. I know the game still recognizes the input as I may enter Options > Keys and set W for anything. It was not a lost bind, as it displays as it should (forward movement).
  • On the other hand, UP ARROW can be used for forward movement without problem.
  • I can't use any glowies, doors, elevators: the mouse pointer does nothing on everything but menus on LBUTTON.
  • If I click ANY menu and move the pointer to any part of screen outside the menus, the pointer shows a target reticle as if I've used an AOE power. Clicking on the screen makes it go away (but doesn't do a thing). Using ESC or Z to CANCEL the power removes the AOE reticle, but the other problems persist. If I click inside a menu and move the pointer, the AOE reticle appears again.
  • Related to the previous problem, with or without the AOE reticle, keys 1 to 8 now try to select a Team member. If I press the key that matches my current position, I receive an error: "Cannot target yourself" (or something like that, as I'm away from the game now).
  • I can't use ANY powers that target enemies, so I can't even Brawl if I must.


I say the problem is temporary because in a few minutes it returns to normal, with no warning or anything like that. In my experience, using chat for a continued time (usually spent saying sorry a lot of times OOC to my fellow team mates) speeds the process.


What has caused the issue, as far as I can tell:

  • Clicking the EXIT button of a mission (I even binded F9 to quit mission thinking it was the only cause, but to no avail) and moving the mouse away from the Nav menu.
  • Clicking on the chat menu to type something and moving the mouse away from the Chat menu.
  • Using a power or toggling a power off (it happened with Mask Presence, Ninja Run, Sprint, and even Rest, all in different trays) and moving the mouse away from the Power tray.


If I quit the game and go to Character Selection while the bug is active, the bug persists when the char is loaded (I haven't tried to switch chars when that happens, and I'll try that as well).

If I quit to Desktop and lauch the game again, the bug disappears.


Last night was the worst offender. It was a medium-lenght door mission to free a captive. Everything was normal, I got the captive, and we needed to lead her to the Exit. I needed Rest, so I clicked on its icon. As soon as I moved the mouse away from the Powers tray the bug started. I was the one who saved the captive, so she followed me. When I got to the elevator (using LBUTTON+RBUTTON or UP ARROW) I couldn't click on it. My team mate was patient and we waited a little, then the enemies respawned right on top of us. I managed to teleport away, but my team mate was down. I used Mask Presence to leave the immediate premises, the captive stop following me, and I moved far away. Eventually the enemies surrounded the captive, my team mate recovered and managed to defeat them, and (as the captive was now saved by him), started following him. He led the captive to the Exit and the mission was successful.

We lost about 20 minutes due to this glitch.


About 3 minutes after I left the mission, the bug went away.


What I think the bug does:

Engages the use of a Power (I don't have and I don't know) that targets an AOE and, as I don't have such Power, it does nothing. As it's expecting a target, it accepts keys 1 to 8 to select team members, but it does nothing to them and I can't be targetted as well. Tried using this "Power" on enemies and friendlies alike, but LBUTTON doesn't target them. If they are targetted by a key (like TAB bound to target_enemy_near), the "Power" does nothing (but I can target and select Next and Previous targets without problem).


So, any ideas about what's happening?

As someone told me on Help channel, I could simply quit to desktop and go back, but imagine this happening during a Task Force or Strike Force (as it occurred already, but the rest of the team was able to proceed while I tried everything to return to normal).


EDIT: I haven't found the cause yet (but I know it affects different alts).

However, I've found a remedy: as soon as I realize the glitch, I alt+tab to any other software, then I alt+tab back -- done, glitch's over. It may reappear in minutes, but as long as I keep away from the chat menu, I'll be safe. 

Edited by Fermmoylle
Remedy found, but bug persists
Link to comment
Share on other sites

6 minutes ago, Pengy said:

It sounds like what happens when the SHIFT key gets "stuck" - when the game drops a key release message and thinks it's still pressed when it isn't. Try tapping each SHIFT key and see if that clears the problem.

Thought about that as well, and tried to press SHIFT over and over again as well. I even checked my Windows Keyboard Config to see if there was some problem coming from outside the game.


Strangely enough, I have only one bind that uses LSHIFT, but it was not used in any of the occurrances of the bug.


EDIT: I've even tried to use my LSHIFT+LBUTTON (which is bound to teleport), but this works as normal while the bug persists.

Edited by Fermmoylle
Link to comment
Share on other sites

I haven't found the cause yet (but I know it affects different alts).

However, I've found a remedy: as soon as I realize the glitch, I alt+tab to any other software, then I alt+tab back -- done, glitch's over. It may reappear in minutes, but as long as I keep away from the chat menu, I'll be safe. 

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
  • Create New...