Jump to content
Sign in to follow this  
Hyperstrike

Every upgrade for 3.0 results in .NET errors and broken program, requiring reinstall.

Recommended Posts

Okay guys.  Every version of 3.0 I've run, when trying to run the upgrade results in a .NET error forcing a crash AND declaring the upgrade "successful".
Afterwards, I'm left with a damaged, non-running install of the program.  Right now I've tried upgrading to 3.0.4.7 and it's done it yet again.

Win 10 Enterprise
24GB RAM
i7 920
Running on a known-good, tested SATA Samsung SSD.

With the update in the program, can we just have the option to open a webpage and download the installer executable?  Rather than just auto-launching an obviously buggy updater?
Because I'm getting HEARTILY sick of having to reinstall multiple times before I wind up with a successful, CURRENT VERSION of the program.

Sorry if I come across bitchy here.  I was trying to just slip in for a couple minutes to look at something before having to get back to work and that's all shot to hell now.


If you want to be godlike, pick anything.

If you want to be GOD, pick a TANK!

Share this post


Link to post
Share on other sites

Do you have .NET 4.8 installed? 



PPM Information Guide                Survivability Tool                  Interface DoT Procs Guide

Time Manipulation Guide             Bopper Builds                      +HP/+Regen Proc Cheat Sheet

Movement Speed: Guide              Recharge Guide                   Base Empowerment: Temp Powers


Bopper's Tools & Formulas           RubyRed's API Tool              Mids' Reborn                       

Share this post


Link to post
Share on other sites
2 hours ago, Bopper said:

Do you have .NET 4.8 installed? 


 

reg query "HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\NET Framework Setup\NDP\v4\full" /v version


HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\NET Framework Setup\NDP\v4\full
    version    REG_SZ    4.8.03761


If you want to be godlike, pick anything.

If you want to be GOD, pick a TANK!

Share this post


Link to post
Share on other sites
4 hours ago, Hyperstrike said:

Okay guys.  Every version of 3.0 I've run, when trying to run the upgrade results in a .NET error forcing a crash AND declaring the upgrade "successful".
Afterwards, I'm left with a damaged, non-running install of the program.  Right now I've tried upgrading to 3.0.4.7 and it's done it yet again.

Win 10 Enterprise
24GB RAM
i7 920
Running on a known-good, tested SATA Samsung SSD.

With the update in the program, can we just have the option to open a webpage and download the installer executable?  Rather than just auto-launching an obviously buggy updater?
Because I'm getting HEARTILY sick of having to reinstall multiple times before I wind up with a successful, CURRENT VERSION of the program.

Sorry if I come across bitchy here.  I was trying to just slip in for a couple minutes to look at something before having to get back to work and that's all shot to hell now.

First and foremost, ranting about something that is provided to you for FREE is not helping your case at all.
With that being said, if you checked either our Discord or our main post here on HC's forums you would notice there is information regarding downloading the app as well as a link to our website for downloading said app's installer.

Edited by crytilis

Quote

I am merely the guy with a keyboard and monitor under the stairs.

 

Share this post


Link to post
Share on other sites
1 hour ago, Ura Hero said:


I've done this after each and every upgrade.
I've stripped the broken install off the machine.  I've stripped the remnants off the machine.
I've even blown out all the registry entries.
Run the repair too.
 


If you want to be godlike, pick anything.

If you want to be GOD, pick a TANK!

Share this post


Link to post
Share on other sites

First: Fine, I'll just stop providing feedback on broken things.  Thanks.

Second: I KNOW the link is there on the forum.  Point well and thoroughly missed.
I was asking that, instead of auto-launching the updater, give people a screen offering the OPTION to manually download the file via a link OR run the updater.

Edited by Hyperstrike

If you want to be godlike, pick anything.

If you want to be GOD, pick a TANK!

Share this post


Link to post
Share on other sites

We have had several issues with the updater in the past, yes. We went through a couple different iterations of it, trying to get new functions to operate correctly with the old code. This latest iteration seems to work just fine, however we have told people in the past to do a fresh install from the website if they're having problems. So I'm going to tell you the same thing.

 

Please fully uninstall Mids from the Windows Settings > Apps & Features screen, and then install a completely fresh copy from the website. If you're still having issues with future updates with this fresh copy, but others aren't, then we can be fairly sure that the issue is on your end and not ours and can troubleshoot from there.

 

Again, we haven't had people complaining about updating about going from the last version to this most recent (except for your report here), so if it breaks again, it's not likely to be Mids specifically, but something related to .NET.

Edited by Felis Noctu

mrb-social2_mini.png.464409b4404c13db31506dbe99d59609.png

Mids' Reborn : Hero Designer

The build planner to make your awesome characters even more awesome!

   
Into the Night "... and so we went into that dark night, for we knew our dawn would come again..."
~ The Meowcronomicon

 

Share this post


Link to post
Share on other sites
5 hours ago, Felis Noctu said:

We have had several issues with the updater in the past, yes. We went through a couple different iterations of it, trying to get new functions to operate correctly with the old code. This latest iteration seems to work just fine, however we have told people in the past to do a fresh install from the website if they're having problems. So I'm going to tell you the same thing.

 

Please fully uninstall Mids from the Windows Settings > Apps & Features screen, and then install a completely fresh copy from the website. If you're still having issues with future updates with this fresh copy, but others aren't, then we can be fairly sure that the issue is on your end and not ours and can troubleshoot from there.

 

Again, we haven't had people complaining about updating about going from the last version to this most recent (except for your report here), so if it breaks again, it's not likely to be Mids specifically, but something related to .NET.


That's just it.  Every version of 3.0 I've run has involved:

Updater set to "Blend".
I have to go in and remove the "New" version, and scrub files and registry.
I then have to go in and remove the "Older" version and ALSO scrub files and registry (mostly just scrubbing registry because the files are already gone).
Manually nuke the remaining folder.
Run the .NET repair tool to make sure .NET is actually okay.
Hit the website, download and install the latest EXE.

And I got to have fun fixing that again tonight when I was time-crunched.
Because my hand twitched.
Hence my suggestion to make the menu item take you to an intermediate screen to gain positive consent or to tell you "Hey!  There's an update.  You can grab it here!  And present a link to the MidsReborn site.


If you want to be godlike, pick anything.

If you want to be GOD, pick a TANK!

Share this post


Link to post
Share on other sites

There seems to be something really broken with .Net. lately.  Like @Hyperstrike I tried everything to get my programs to work.  Mids wasn't affected, but I couldn't use my mail program and TurboTax wouldn't run.  I never did figure it out after two months of Googling and tons of help desk support.  I finally gave up and did a reinstall of Windows and it all woks fine now.  Not that I am suggesting reinstallation as a fix, just information that this probably isn't just a one person issue.

Edited by Ura Hero

Share this post


Link to post
Share on other sites
Sign in to follow this  

×
×
  • Create New...