Jump to content

[How2] Basic Installation Guide [MacOS - Apple M1]


WanderingAries
 Share

Recommended Posts

I tried to download CoH launcher again 

I tried to install it 

I am still not moving past this here 

I still have the feeling that the path is wrong on my computer 

I will try the default MacintoshHD/users/.....

Screen Shot 2021-03-12 at 5.43.00 PM.png

Link to comment
Share on other sites

11 hours ago, WanderingAries said:

Confirming that the .privatewine folder is created the Moment the Launch CoH.app is first run (activating Wine installer). This is the location that the Wine will aim at for the purposes of the game to function correctly.

So does this help me ?

What do I want to do with this info ?

Link to comment
Share on other sites

11 hours ago, WanderingAries said:

Confirming that the .privatewine folder is created the Moment the Launch CoH.app is first run (activating Wine installer). This is the location that the Wine will aim at for the purposes of the game to function correctly.

 

I found no such folder in my computer 


I now think the problem is Wine. 

How can we check and solve ?

Link to comment
Share on other sites

Quote

Confirming that the .privatewine folder is created the Moment the Launch CoH.app is first run (activating Wine installer). This is the location that the Wine will aim at for the purposes of the game to function correctly.

Remember that this folder is the only Hidden one we deal with directly, so you have to unhide things with the:

Command + Shift + "." (period)

 

Again, the folder is located at (based on my setup): //Big Sur/Users/USERNAME/.privatewine

 

Unless you're looking to "clean remove" the game or the files are damaged, then I believe Manga said you can leave them be. I just wipe everything out when I'm trying a "fresh install".

 

52 minutes ago, Voltak said:

I changed the path and I get this 

 

Remember, the path is relative and will be the same for Everyone

 

53 minutes ago, Voltak said:

Could it MalwareBytes now ?

 

Maybe, but only if you've activated the free trial where it scans, otherwise it's manual use only. This particular issue is pre-HC Launcher I believe, but because I don't get the issue, then I'm not used to the troubleshoot. Normally, after having all the permissions in place, you don't get this stuff. @Manga, to you remember what we had to do to sort that out?

OG Server: Pinnacle  <||>  Current Primary Server: Torchbearer  ||  Also found on the others if desired


Installing CoX:  Windows  ||  MacOS  ||  MacOS for M1  <||>  Migrating Data from an Older Installation


Clubs: Mid's Hero Designer  ||  PC Builders  ||  HC Wiki  ||  Jerk Hackers


Old Forums  <||>  Titan Network  <||>  The City Representative (Info site for all servers)  <||>  Heroica! (by @Shenanigunner)

 

Link to comment
Share on other sites

I do want to bring the following fact up for some consideration, if it helps

Had I not changed the path name, I would not know that AV was still interfering 

Using the path name that you gave me did not notify me of that issue

Ok, I stopped Malwarebytes

Still not progressing

I will try to uninstall it , Malwarebytes

Link to comment
Share on other sites

5 minutes ago, Voltak said:

I do want to bring the following fact up for some consideration, if it helps

Had I not changed the path name, I would not know that AV was still interfering 

Using the path name that you gave me did not notify me of that issue

Ok, I stopped Malwarebytes

Still not progressing

I will try to uninstall it , Malwarebytes

 

Any location other than the default seems to trigger that, but it Might be related, yes.

OG Server: Pinnacle  <||>  Current Primary Server: Torchbearer  ||  Also found on the others if desired


Installing CoX:  Windows  ||  MacOS  ||  MacOS for M1  <||>  Migrating Data from an Older Installation


Clubs: Mid's Hero Designer  ||  PC Builders  ||  HC Wiki  ||  Jerk Hackers


Old Forums  <||>  Titan Network  <||>  The City Representative (Info site for all servers)  <||>  Heroica! (by @Shenanigunner)

 

Link to comment
Share on other sites

I bet this is something So stupid-silly-easy that it's gonna bite when it's sorted out.

OG Server: Pinnacle  <||>  Current Primary Server: Torchbearer  ||  Also found on the others if desired


Installing CoX:  Windows  ||  MacOS  ||  MacOS for M1  <||>  Migrating Data from an Older Installation


Clubs: Mid's Hero Designer  ||  PC Builders  ||  HC Wiki  ||  Jerk Hackers


Old Forums  <||>  Titan Network  <||>  The City Representative (Info site for all servers)  <||>  Heroica! (by @Shenanigunner)

 

Link to comment
Share on other sites

I guess we'll need to wait for Manga. Might wanna move commenting to their Mac thread from here as this is a Mac issue, not just M1 I believe. More people will look at it as well and someone May have already sorted it. IDK, it's usually just one and done with the HC Launcher. 😕

OG Server: Pinnacle  <||>  Current Primary Server: Torchbearer  ||  Also found on the others if desired


Installing CoX:  Windows  ||  MacOS  ||  MacOS for M1  <||>  Migrating Data from an Older Installation


Clubs: Mid's Hero Designer  ||  PC Builders  ||  HC Wiki  ||  Jerk Hackers


Old Forums  <||>  Titan Network  <||>  The City Representative (Info site for all servers)  <||>  Heroica! (by @Shenanigunner)

 

Link to comment
Share on other sites

IDK offhand. That's something Manga would know I'm sure.

OG Server: Pinnacle  <||>  Current Primary Server: Torchbearer  ||  Also found on the others if desired


Installing CoX:  Windows  ||  MacOS  ||  MacOS for M1  <||>  Migrating Data from an Older Installation


Clubs: Mid's Hero Designer  ||  PC Builders  ||  HC Wiki  ||  Jerk Hackers


Old Forums  <||>  Titan Network  <||>  The City Representative (Info site for all servers)  <||>  Heroica! (by @Shenanigunner)

 

Link to comment
Share on other sites

I'm on a fresh new Mac mini M1 16 GB/512GB, straight out of the box.

 

I've attempted the install instructions as listed in the first post.  I can bring up the new Homecoming Launcher (dragging it from the upper left so it's fully visible).  I can download the Homecoming client from the launcher (confirmed by seeing the installed files in the coh directory).  I click the run button on Homecoming, and the minimized window appears in the upper left corner.  However, entering "command" + "enter" (assuming the keypad "enter") does nothing. I look in the menubar and there's an option for "Fullscreen", but when I select that, the minimized window bar zooms large, then it becomes a black screen with no way out except for command-tabbing to other apps that are up. Then I have to quit it from the dock to remove it completely (though at least the launcher recognizes that it's been killed, and goes back to the "Ready" state for homecoming.  I'm not sure what's going on here, or how it can be addressed further.

 

Link to comment
Share on other sites

14 minutes ago, pjmoyer said:

I'm on a fresh new Mac mini M1 16 GB/512GB, straight out of the box.

 

However, entering "command" + "enter" (assuming the keypad "enter") does nothing. I look in the menubar and there's an option for "Fullscreen", but when I select that, the minimized window bar zooms large, then it becomes a black screen with no way out except for command-tabbing to other apps that are up. Then I have to quit it from the dock to remove it completely (though at least the launcher recognizes that it's been killed, and goes back to the "Ready" state for homecoming.  I'm not sure what's going on here, or how it can be addressed further.

 

 

An update - by plugging in a separate keyboard (a standard ansi 102 key type), and using the "window icon" and "enter" keys together, I was able to get the correct window behavior to happen - fullscreen mode with the login available and characters loaded.  This now persists over starts and stops of COH from the new launcher.  I think it may be an issue with my older apple keyboard - even though it has a number keypad built in, those keys never seem to be recognized correctly in COH.  So not insurmountable, but still annoying to have to do that.

Link to comment
Share on other sites

2 minutes ago, pjmoyer said:

 

An update - by plugging in a separate keyboard (a standard ansi 102 key type), and using the "window icon" and "enter" keys together, I was able to get the correct window behavior to happen - fullscreen mode with the login available and characters loaded.  This now persists over starts and stops of COH from the new launcher.  I think it may be an issue with my older apple keyboard - even though it has a number keypad built in, those keys never seem to be recognized correctly in COH.  So not insurmountable, but still annoying to have to do that.

 

Very true. I believe that the Mac key is actually called Return and has an arrow symbol that was common on all typewriters. Location usually midway up along the right edge of the alpha keys. Same as Enter on "normal" keyboard. And you are correct that the Menu Bar commands don't work as intended.

OG Server: Pinnacle  <||>  Current Primary Server: Torchbearer  ||  Also found on the others if desired


Installing CoX:  Windows  ||  MacOS  ||  MacOS for M1  <||>  Migrating Data from an Older Installation


Clubs: Mid's Hero Designer  ||  PC Builders  ||  HC Wiki  ||  Jerk Hackers


Old Forums  <||>  Titan Network  <||>  The City Representative (Info site for all servers)  <||>  Heroica! (by @Shenanigunner)

 

Link to comment
Share on other sites

38 minutes ago, WanderingAries said:

 

Very true. I believe that the Mac key is actually called Return and has an arrow symbol that was common on all typewriters. Location usually midway up along the right edge of the alpha keys. Same as Enter on "normal" keyboard. And you are correct that the Menu Bar commands don't work as intended.

 

Well, I tried "command + return" when I was trying to figure this out, and it didn't seem to work then either.  Maybe I should try and force it back to windowed and test it that way again, now that I know I can use a second keyboard to undo the issue.

 

Now I just need to adjust to the higher resolution and graphics quality, and repositioning all my trays... 🙂

Link to comment
Share on other sites

41 minutes ago, pjmoyer said:

 

Well, I tried "command + return" when I was trying to figure this out, and it didn't seem to work then either.  Maybe I should try and force it back to windowed and test it that way again, now that I know I can use a second keyboard to undo the issue.

 

Now I just need to adjust to the higher resolution and graphics quality, and repositioning all my trays... 🙂

 

It'll either toggle or it won't. But test away. ^.^

 

Don't touch the in-game rez (actual dimensions)!!!  Anything other than native doesn't work as intended and will cause you trouble. Graphic Quality, have at it.

OG Server: Pinnacle  <||>  Current Primary Server: Torchbearer  ||  Also found on the others if desired


Installing CoX:  Windows  ||  MacOS  ||  MacOS for M1  <||>  Migrating Data from an Older Installation


Clubs: Mid's Hero Designer  ||  PC Builders  ||  HC Wiki  ||  Jerk Hackers


Old Forums  <||>  Titan Network  <||>  The City Representative (Info site for all servers)  <||>  Heroica! (by @Shenanigunner)

 

Link to comment
Share on other sites

  • 2 months later

Hello, thanks for the guide. ... however, I seem to be having the same problem Voltak described. Was that resolved? 

 

[new MacBook Air, pretty much straight out of the box. Have added/changed almost nothing before 

 

I'm stuck here:

 

1664745216_ScreenShot2021-05-23at6_48_43AM.png.24448f24df52b1a5fa27c9dc80547372.png

Link to comment
Share on other sites

1 hour ago, SaintTzu said:

Hello, thanks for the guide. ... however, I seem to be having the same problem Voltak described. Was that resolved? 

 

[new MacBook Air, pretty much straight out of the box. Have added/changed almost nothing before 

 

I'm stuck here:

 

1664745216_ScreenShot2021-05-23at6_48_43AM.png.24448f24df52b1a5fa27c9dc80547372.png

 

If you haven't already, restart the Mac and try again. Manga updated the installer since this was last updated to improve/simplify the process, but some people have been experiencing Permissions based issues that they found a way to deal with.

OG Server: Pinnacle  <||>  Current Primary Server: Torchbearer  ||  Also found on the others if desired


Installing CoX:  Windows  ||  MacOS  ||  MacOS for M1  <||>  Migrating Data from an Older Installation


Clubs: Mid's Hero Designer  ||  PC Builders  ||  HC Wiki  ||  Jerk Hackers


Old Forums  <||>  Titan Network  <||>  The City Representative (Info site for all servers)  <||>  Heroica! (by @Shenanigunner)

 

Link to comment
Share on other sites

  • 3 months later

I have had some of the problems mentioned in this thread in the past on Macs, but I can happily report that I do have this running on an M1 mac.  I can't tell you exactly what I did, but in general I followed the instructions to get Island Rum working, then installed the HC launcher.  Had to run sudo spctl --master-disable to get the OS to stop complaining about the package being "damaged", but after that it worked.

Link to comment
Share on other sites

  • 3 months later

I've got CoH running on my M1 MacBook Air!

I got it running by following this guide (thank you!)

 

One issue though: The audio seems to be locked to my MacBook speakers. I can't get Bluetooth AirPods or the standard audio jack to work with headphones...

 

Anyone else have this issue or a possible fix?

 

 

Link to comment
Share on other sites

30 minutes ago, Flat Line said:

I've got CoH running on my M1 MacBook Air!

I got it running by following this guide (thank you!)

 

One issue though: The audio seems to be locked to my MacBook speakers. I can't get Bluetooth AirPods or the standard audio jack to work with headphones...

 

Anyone else have this issue or a possible fix?

 

 

 

I'm assuming you have the output device set correctly in system preferences right? I don't know enough of how the launcher works with the OS beyond that.

OG Server: Pinnacle  <||>  Current Primary Server: Torchbearer  ||  Also found on the others if desired


Installing CoX:  Windows  ||  MacOS  ||  MacOS for M1  <||>  Migrating Data from an Older Installation


Clubs: Mid's Hero Designer  ||  PC Builders  ||  HC Wiki  ||  Jerk Hackers


Old Forums  <||>  Titan Network  <||>  The City Representative (Info site for all servers)  <||>  Heroica! (by @Shenanigunner)

 

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
×
  • Create New...