Jump to content

Blaster - Ninja Training - Shinobi: Criticals broken while exemplaring from L50


Recommended Posts

Short version: As a level 50 character, the Critical proc portion of the Blaster secondary Ninja Training power Shinobi appears to be broken when exemplaring to levels below 45. At or above 45 they function as normal.

 

Elaboration: I noticed while doing some arcs in Ouroboros on my level 50 Dual Pistols/Ninja Training blaster that no critical attacks from Shinobi were being generated. The arc I was on was level 24, so the power was available, and I verified that it was on by retoggling it several times and continuing to play, but this did not fix the issue.

 

After the session ended I checked the combat logs and noticed that not a single critical had been generated over the course of the Ouroboros arc. However, I did see the following message in the log when retoggling the power:

597328449_ShinobiL24.png.09338d1f44326dfeb72683c3400cb47b.png

 

Curious, I tried retoggling the power after using Ouroboros and Strike Forces to exemplar at various levels where Shinobi would be available:

1732340177_ShinobiL30.png.e851ecc75de1db6172dcb996f2045f92.png

 

59996438_ShinobiL39.png.1ad662c037ccee36f4f7d90150db5d0f.png

 

1589577896_ShinobiL40.png.49920b1a8eb03ba1043ba96c50883755.png

 

When I exemplared at level 45+ I no longer received the message about not being able to use Shinobi Skills. The message that appears is similar to the one generated while zoning when exemplared regarding Incarnate abilities when fighting while exemplared: 

1414874064_Shinobizoning.png.bb732bbcb8c29ba06901aa362420c9de.png

 

Edited by ViciousCabaret
Cleaned up a little.
Link to post
Share on other sites

@ViciousCabaret, can you try detoggling Shinobi, logging out while still while on an arc that exmplars you, and seeing if it is still broken when you toggle it on after login?

 

I see that the power is flagged ignore_level_gained: false. I am wondering if it's possible that the granted power is not replaced if you already have it. Exemplaring below level 45 would cause you to lose a power you gained at level 50, and if you turned Shinobi on while level 50, that would mean you "earned" Shinobi Skills at level 50.

 

The attribmod itself is set to "replace" stacking, but I have no idea if that actually means it replaces the granted power if you already have it.

 

I am wondering if logging out with Shinobi off means you come back without Shinobi Skills, and then can grant it to yourself at a lower level, allowing it to function.

 

If so, we know how to fix it!

Edited by UberGuy
Link to post
Share on other sites
Posted (edited)

Per your request, I started an Ouro arc (in this case 20-24 - Retrieve Crash's Shipment) which exemplared my character to level 24, then toggled off Shinobi, logged out, logged back into the character, and toggled it back on. I received the message in the log about not being able to use Shinobi skills at level 24.

 

However, when I zoned into Sharkhead, and after that the mission map, I noticed that I received no message about not being able to use Shinobi skills along with the messages regarding Incarnate abilities. Criticals happened as expected during combat, as can be seen in the log.

 

1212214757_1-Entermissionmap.png.3cdaeaa36eb6a979155d87e3af989cea.png

 

When I toggled off then toggled back on Shinobi, I again received the message about not being able to use Shinobi skills, and during more combat encounters I observed no Criticals, and could not find any in the logs after the retoggling.

 

1027464343_2-RetoggleShinobi.png.2d7e76e86f27dd75e670406060927c32.png

 

I exited the mission before completing it to see if Shinobi would again generate Criticals. After loading into Sharkhead, I again received the messages about Incarnate abilities not functioning at L24, but not the message about Shinobi. I engaged in combat to verify that Criticals would happen, and they did.

 

1545930073_3-Exitmissionlog.png.4f3545f07c783cd44304fe588b1787a4.png

 

I again toggled off the power while on Sharkhead, then toggled it back on, again receiving the expected message about not being able to use Shinobi skills and again not generating any Criticals after a fair amount of combat.

 

Thus, it appears my initial report was incorrect, and the issue appears to be retoggling Shinobi which prevents the power from generating Critical damage while exemplared. The Ouro mission where I observed no Criticals was one in which an escort is required, one of the sort that cannot see through stealth and thus needed me to detoggle the power, the significance of which did not occur to me to report before. I do not recall seeing any Criticals in prior missions on the arc I was on in my first report (20-24: A Web of Intrigue), but I can test further.


EDIT: After running the first mission of the original Ouro arc I was on in the first report I saw several Criticals, so it was probably my memory at play with my thinking that no Criticals had occurred prior the escort mission in that arc.

Edited by ViciousCabaret
Link to post
Share on other sites
Posted (edited)

On an intuition I made a Dual Pistols/Ninja Training Blaster on the Test Server, set their character level to 29, and granted the Ouroboros Portal power to see if Shinobi Criticals would work after retoggling the power while exemplared to 24. I used the same mission (Retrieve Crash's Shipment) for as much consistency as possible. After zoning into Sharkhead, Criticals worked as before. Upon retoggling the power, there was no message about Shinobi skills and Criticals continued to occur.

 

However, when I used Ouroboros to exemplar down to level 19 using another mission (High Tech Gold), the same issue with Criticals came up. They would function if Shinobi was toggled on before zoning into a map/mission, but if the power was toggled off then on again the message regarding using Shinobi skills would appear in the combat log and Criticals would cease to function.

 

249072154_Test1-RetoggleCL19.png.4256170bc709c980fd0c8d05050ed0cb.png

 

After that, I set my character level to 30 and trained, then again started the Retrieve Crash's Shipment arc. Upon toggling off and on Shinobi I received the message regarding not using Shinobi skills.

 

343235567_Test2-Failureat30.png.540a9c95c8fe18ec91ff7f539e708f13.png

 

My observation is that when Shinobi is toggled off and then on again, the Critical portion of the power is being treated as if it were a power granted at a characters ACTUAL level, rather than their current exemplared level/combat level, and obeying the +5 character level exemplar restriction . This would explain why the power can be toggled off and on and have Criticals function at level 29, but not at level 30. I don't know the code at all, so I can't make a supposition as to why the power works normally after zoning but ceases to do so after retoggling it.

Edited by ViciousCabaret
Link to post
Share on other sites

So I think I stumbled across the root cause, and if I'm right, it's suuuuper annoying, but still easy for the devs to fix.

 

Why is it annoying? Well, I went looking for other powers that work like Shinobi does - powers that grant you a Global Boost that's a PPM damage proc. Two powers I found were Bio Armor's Offensive Adaptation and Plant Manipulation's Toxins. (Hybrid Assault does this too, but it can't be used when exemplared down low the way all these others can.)

 

The obnoxious thing was that nothing in these other proc-granting powers looks meaningfully different from Shinobi. So why do they work when you're exemplared? (They do work.)

 

It seems that the answer is ... magic. 

 

Here are the boosts the three different powers grant.

redirects.blaster_ninja_training.shinobi_proc

temporary_powers.temporary_powers.offensive_adaptation_proc 

temporary_powers.temporary_powers.plant_manipulation_toxins

 

The difference is obvious, visually, but it never occurred to me that it could matter. But casting around for any explanation, I went code diving in the SCoRE code.

 

It turns out that powers in the "temporary_powers" power category* get a magical, hard-coded pass on caring what level you were when you earned the power. Shinobi isn't in the temp power category, so its "level earned" is checked. When you're level 50, you apparently grant yourself the power at level 50 (even when you grant it to yourself while exemplared), and when you're exemplared to too low below 50, it isn't allowed to function. That's why you get the message about it not working at your current level.

 

Fortunately, in that same code is the solution I guessed at earlier. Powers can be flagged to ignore their earned level for exemplar purposes. That's how all accolade powers are set up, for example.

 

It's possible the HC devs have updated the code I looked at, but honestly, this seems like something that probably is still the same. If it's not, I have no idea why OA and Toxins work when exemplared but Shinobi breaks.

  • Thanks 1
Link to post
Share on other sites

In case you guys didn't catch it, it looks like this bug is being patched in i27p2, the newest update mentions fixing the crit proc when exemped.

Currently playing on Indomitable as @Zork Nemesis; was a Protector native on live.

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
×
×
  • Create New...