Jump to content

OSX- Launcher Unresponsive?


Recommended Posts

The launcher has been working fine for me for months, even worked this morning, but starting now, it doesn't open correctly. The window can't be clicked on or interacted with in any way, and the Wine taskbar is also unresponsive. The only solution is to force-quit. Is anyone else having this problem on their Mac? I'll probably uninstall and reinstall, but that seems a shame.

Edited by VulnaviaPhibes
Link to post
Share on other sites
  • VulnaviaPhibes changed the title to OSX- Launcher Unresponsive?

Update: it seems like it might be a problem with Wine. It was the Wine64 preloader that was freezing before, and now that I've uninstalled, the Wine64 loader is freezing again and failing to complete the setup and install the launcher/game.

Link to post
Share on other sites
  • Homecoming Team

There was a launcher update tonight, so it seems like it may be more than a coincidence.

 

It was a very minor update -- I can't see how the certificate changes could possibly affect that.

 

The only possibility I can think of is that the new version does some detection for Windows 11, but it has to use an internal NT API because the SDKs aren't updated with an official way to do that yet. So if wine is reporting itself as Windows 10, and if it has an RtlGetNtVersionNumbers in ntdll.dll that is broken, that maybe could be causing the preloader to crash?

 

I'm going to publish a new build in little while that avoids that entire code path when running under Wine, just in case. Will post here to try to install it again. The installer automatically pulls the latest build so if that's the issue it should resolve it.

Link to post
Share on other sites

I'm seeing the same, or at least a very similar issue, tho I haven't tried re-installing yet.

 

I did decide to 'check for updates' given the above, and while the UI isn't 'frozen' as if I'd tried to launch, the 'checking for updates' process seems not to be making any progress.

 

My version is listed as 27.2.4470, if that helps.

 

--

Pauper

 

Link to post
Share on other sites
39 minutes ago, Number Six said:

A new build has just been released, can you try the installer and see if there's any change?

The problems I mentioned with the installer and launcher seem to be fixed- it installs properly, and the launcher doesn't freeze or crash upon opening. Thank you! ^_^

 

However, there seems to be a new problem. When I try to download Homecoming, the progress bar stays stuck at 0% permanently, and trying to close the launcher during this process causes it to freeze up and become non-responsive exactly like it did before.

Link to post
Share on other sites

I'm likewise apparently freezing up when trying to start Homecoming, or verify homecoming, or download either Prerelease or Beta.  I was playing a few hours ago, but now I'm having no luck at all.  I'm happy to share any files you wish if it helps you troubleshoot.

Link to post
Share on other sites
  • Homecoming Team

@golias The log file shows you have build 4518, which is the one that is apparently causing wine to crash on MacOS.

 

If you don't want to reinstall in place, you can find your [CoH]/bin/win64/launcher.exe file and delete it, then replace it with this one: https://manifest.cohhc.gg/launcher/hcinstall-catalina.exe

(ignore the filename and rename it to launcher.exe).

 

Also delete [CoH]/settings/launcher/packages/launcher.json

and [CoH]/settings/launcher/bootstrap.json

 

That should force it to download 4550 and you can see if that works.

 

If it doesn't, what we may have to do for now is manually roll back to a previous launcher version and set it to not auto-update. That's a bit more involved process but if I can't figure out why it's suddenly misbehaving in wine we may have to go down that road.

  • Thumbs Up 2
Link to post
Share on other sites
Posted (edited)

It doesn't seem to be working for me, unfortunately. I've checked the launcher.log and I'm running build 4520, but I'm still having the same game files installation issue.

 

EDIT: As a secondary concern (The log says I'm running on 4520, not 4518, so this is probably not the issue)- my computer won't acknowledge the launcher.exe you linked above as "safe," even if I open it manually, for some reason it forgets that I did that when it comes time for the launcher to use it, and either cancels out or trashes the file. @golias how did you manage to get around that?

Edited by VulnaviaPhibes
Link to post
Share on other sites

I hit "cancel" when that happened and was getting ready to edit my permissions when it ran anyway.  ˘\_(ツ)_/˘ 

[edit: and apparently it remembered that the app is "safe" when I launched a second time.  So I got that going for me.  Which is nice.]

Edited by golias
Link to post
Share on other sites

Great news for anyone having this problem- Island Rum still works just fine! It will give you an error message when it tries to install Wine, but then it will go on to install and run the game without trouble. That's obviously not a sustainable fix lmao, but it does allow you to play the game. ^_^

Link to post
Share on other sites

I'll have to check this out as I observed the same behavior when doing my occasional update. Window can only be force quit (the launcher app itself, not Wine as far as I can remember.

 

M1 platform

OG Server: Pinnacle  <||>  Current Primary Server: Torchbearer  ||  Also found on the others if desired


Installing CoX:  Windows  ||  MacOS  ||  MacOS for M1  <||>  Migrating Data from an Older Installation


Clubs: Mid's Hero Designer  ||  PC Builders  ||  HC Wiki  ||  Jerk Hackers


Old Forums  <||>  Titan Network  <||>  The City Representative (Info site for all servers)  <||>  Heroica! (by @Shenanigunner)

 

Link to post
Share on other sites

I'm using an M1 with the latest developer Monterey build (21A5534d)

 

Similarly, my launcher started dying around the same time I updated to beta2, so not sure if its the launcher or the OS causing a problem. Have tried various methods to get going again without success.

Link to post
Share on other sites
On 9/30/2021 at 11:43 PM, Number Six said:

@golias The log file shows you have build 4518, which is the one that is apparently causing wine to crash on MacOS.

 

If you don't want to reinstall in place, you can find your [CoH]/bin/win64/launcher.exe file and delete it, then replace it with this one: https://manifest.cohhc.gg/launcher/hcinstall-catalina.exe

(ignore the filename and rename it to launcher.exe).

 

Also delete [CoH]/settings/launcher/packages/launcher.json

 

That should force it to download 4520 and you can see if that works.

 

If it doesn't, what we may have to do for now is manually roll back to a previous launcher version and set it to not auto-update. That's a bit more involved process but if I can't figure out why it's suddenly misbehaving in wine we may have to go down that road.

 

I had the same problem, followed these instructions, am in game now.  Thanks!

 

Link to post
Share on other sites

I'm gonna test this out tonight on the iMini / M1 as I know it was doing this.

OG Server: Pinnacle  <||>  Current Primary Server: Torchbearer  ||  Also found on the others if desired


Installing CoX:  Windows  ||  MacOS  ||  MacOS for M1  <||>  Migrating Data from an Older Installation


Clubs: Mid's Hero Designer  ||  PC Builders  ||  HC Wiki  ||  Jerk Hackers


Old Forums  <||>  Titan Network  <||>  The City Representative (Info site for all servers)  <||>  Heroica! (by @Shenanigunner)

 

Link to post
Share on other sites

Confirming the last line of the log file:

 

Quote

2021-10-03 01:34:10    pkginstall: Beginning upgrade from launcher:1.4486 to launcher:1.4520

 

 

I did the file deletion/replacement as listed above and also ran into this:

 

On 10/1/2021 at 12:43 AM, Number Six said:

If you don't want to reinstall in place, you can find your [CoH]/bin/win64/launcher.exe file and delete it, then replace it with this one: https://manifest.cohhc.gg/launcher/hcinstall-catalina.exe

(ignore the filename and rename it to launcher.exe).

 

Also delete [CoH]/settings/launcher/packages/launcher.json

 

1890687302_ScreenShot2021-10-03at1_44_02AM.png.f3fac760227917d381d04dc0d2e52d0b.png

 

As someone else mentioned above, clicking "Cancel" will allow the launcher to load and you don't get it a second time. I have not tried rebooting the Mac to see if that changes anything, but I doubt it will.

 

Edit: Just reiterating that I'm running Big Sur 11.6 on the M1 Mac Mini

Edited by WanderingAries

OG Server: Pinnacle  <||>  Current Primary Server: Torchbearer  ||  Also found on the others if desired


Installing CoX:  Windows  ||  MacOS  ||  MacOS for M1  <||>  Migrating Data from an Older Installation


Clubs: Mid's Hero Designer  ||  PC Builders  ||  HC Wiki  ||  Jerk Hackers


Old Forums  <||>  Titan Network  <||>  The City Representative (Info site for all servers)  <||>  Heroica! (by @Shenanigunner)

 

Link to post
Share on other sites
  • Homecoming Team

Just published build 4529. I have no idea if it will help or not since the changes that "caused" this were so minimal and don't make any sense. But it includes a reversion of one of those* so maybe it will make Rosetta happy. Existing installs will probably have to delete the current exe and replace it again, while new installs that are stuck in "completing" may be better off just deleting it and running the installer again.

 

* I can't revert the certificate update since that will break things for people due to the CA expiring on Sep 30.

  • Thumbs Up 1
Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
×
×
  • Create New...