Jump to content
Homecoming is undergoing emergency maintenance. We'll be back shortly. ×
Homecoming is undergoing emergency maintenance. We'll be back shortly.
Pine

Pine's Hero Designer 2.22

Recommended Posts

I noticed the damage bars in the Info tab are showing the DPS of the powers. How do I get it to show the damage of one activation?

I was having the same issue.  Finally found the solution.  Click on "View" then at the bottom is the option to "Show Damage per Activation".

Share this post


Link to post
Share on other sites

 

Is this hosted/mirrored somewhere other than DropBox?  My corporate overlords don't allow us to use DropBox, so I can't get it here at work.  *sob*

 

 

We now have a local installer (for copying/thumbdrives/offline install) at https://github.com/ImaginaryDevelopment/imaginary-hero-designer/releases tagged as Clickonce local installer.

and a web installer (that should provide auto updating and update checking) at https://imaginarydevelopment.github.io/imaginary-hero-designer/publish/publish.htm

 

Of note: windows 10 must have tried to stop me at least 3 times running the installer, and then allowing it to install, then allowing the app to launch. So much as Pine described before, Windows doesn't recognize the software so it will make it more difficult for you to not think about letting it run.

 

Share this post


Link to post
Share on other sites

Having issues importing data chunks as well.

 

Would you be so kind as to describe the issue?

Share this post


Link to post
Share on other sites

Hello!  I wanted first of all to thank you for the tremendous amount of work you've put into updating Mid's--it is a lifesaver for me, I can't thank you enough!

 

On the older version of Pine's (the one that was available from a before the servers were active), I noticed a bunch of errors that I fixed, such as missing powersets and whatnot.  I'm very happy that you were able to fix that, however, I noticed some bugs and possible oversights that remained after the fact.  I made some minor edits to the database and added 2 images to fix what was previously missing.

 

Unfortunately the way the data files are currently implemented doesn't allow merging of changes. Pine has been working very hard at the database files and a tool to merge what you've done with that he's done doesn't exist. We're working on a way to make concurrent db updates more viable. Tracking issue at https://github.com/ImaginaryDevelopment/imaginary-hero-designer/issues/17

Share this post


Link to post
Share on other sites

Is there a way to bypass needing the .NET Framework v3.5 for this? For some reason, I could run the previous version of Pine's (2.21) just fine on my work computer, but 2.22 tells me it requires .NET Framework v3.5, which I can't install given our version of Windows and user permissions.

 

Is there something I'm overlooking that causes this additional requirement?

 

Well, the .NET Framework 3.5 was released way back in 2007, if I understand the previous body of work correctly this change is still bringing the code up to a > 10 yr old standard for .net applications. I'm not sure which way forward would be better for the user base. .Net 3.5 goes back to Windows XP.

 

.Net 3.5.1 was included Windows 7.

.Net 4.5 was included in Windows 8, Windows 2012, Windows 2012R2.

.Net 4.6 is included on Windows 10.

More info (and any mistranslated/quoted data) at https://blogs.msdn.microsoft.com/astebner/2007/03/14/mailbag-what-version-of-the-net-framework-is-included-in-what-version-of-the-os/

 

It may be that you're using a newer OS, so moving up to 3.5 requires installing an older framework than you already have. Whereas the even older one may have been present from installing other programs that used it already.

 

So we could move forward to .Net 4.5 bringing us up to many newer features and capabilities in the code but possibly making a certain portion of users have to install 4.5, others already have it.

We could move forward to .Net 4.6 bringing more, but making another portion of users have to install, with others already having that.

4.7 may be a different beast. It hasn't come with a windows release, but has come in many Windows 10 updates.

 

Somewhere in 4.7 or .Net Core they switched to not requiring a framework install any longer. The installers/deploys come with all the necessary libraries. Since we have no telemetry/tracking in the software (and no where that could even capture that info).

 

------

Begin opinion and speculation on the path forward:

 

We will likely move as the codebase drives us.

These are my personal thoughts on the matter and do not reflect any discussion or agreement with Pine. I intend to always put his input first on decisions of this nature(barring a schism that many partnerships/companies/relationships sometimes exhibit).

Share this post


Link to post
Share on other sites

Can you do attuned enhancements in the program?

Not that I'm aware of. Maybe Pine knows more on that

Share this post


Link to post
Share on other sites

Can you do attuned enhancements in the program?

I just put them in as enhancements at the max level for their set. Since the only difference is exemplaring that works fine for doing builds.


Defender Smash!

Share this post


Link to post
Share on other sites

Is there a way to bypass needing the .NET Framework v3.5 for this? For some reason, I could run the previous version of Pine's (2.21) just fine on my work computer, but 2.22 tells me it requires .NET Framework v3.5, which I can't install given our version of Windows and user permissions.

 

Is there something I'm overlooking that causes this additional requirement?

 

Well, the .NET Framework 3.5 was released way back in 2007, if I understand the previous body of work correctly this change is still bringing the code up to a > 10 yr old standard for .net applications. I'm not sure which way forward would be better for the user base. .Net 3.5 goes back to Windows XP.

 

.Net 3.5.1 was included Windows 7.

.Net 4.5 was included in Windows 8, Windows 2012, Windows 2012R2.

.Net 4.6 is included on Windows 10.

More info (and any mistranslated/quoted data) at https://blogs.msdn.microsoft.com/astebner/2007/03/14/mailbag-what-version-of-the-net-framework-is-included-in-what-version-of-the-os/

 

It may be that you're using a newer OS, so moving up to 3.5 requires installing an older framework than you already have. Whereas the even older one may have been present from installing other programs that used it already.

 

So we could move forward to .Net 4.5 bringing us up to many newer features and capabilities in the code but possibly making a certain portion of users have to install 4.5, others already have it.

We could move forward to .Net 4.6 bringing more, but making another portion of users have to install, with others already having that.

4.7 may be a different beast. It hasn't come with a windows release, but has come in many Windows 10 updates.

 

Somewhere in 4.7 or .Net Core they switched to not requiring a framework install any longer. The installers/deploys come with all the necessary libraries. Since we have no telemetry/tracking in the software (and no where that could even capture that info).

 

------

Begin opinion and speculation on the path forward:

 

We will likely move as the codebase drives us.

These are my personal thoughts on the matter and do not reflect any discussion or agreement with Pine. I intend to always put his input first on decisions of this nature(barring a schism that many partnerships/companies/relationships sometimes exhibit).

 

Considering Windows 7 is a dead OS walking, and that .NET 5.0 is on track and incompatible with earlier stuff, best to just jump to .NET 4.8 IMO.  That way it will stay supported for a bit, longer than .NET 3.5 or 4.5 at any rate.

Share this post


Link to post
Share on other sites

Anyone know of how I could get Pine's to possibly run on Chrome OS? I'm not expecting it, but it would be amazing if I could get it to work.

 

Take a look here.

Share this post


Link to post
Share on other sites

The defensive numbers listed under the Concealment pool powers such as Stealth and Grant Invisibility lists the unsuppressed numbers toward defense, which is quite misleading.

 

Also, Rain of Arrows cast time is not correct after the buff reducing its cast-time/recharge.

Share this post


Link to post
Share on other sites

The defensive numbers listed under the Concealment pool powers such as Stealth and Grant Invisibility lists the unsuppressed numbers toward defense, which is quite misleading.

 

Go to Options -> Configuration -> Effects and Math

 

On the right will be a list of suppression effects, one of them is "Attacked". Click it and press OK. All your power effects will be reflected as if though you were in combat.

 

Illusion Control's Phantom Army recharge is not affected by either Spiritual or Agility Alphas on Pines.

Share this post


Link to post
Share on other sites

.Net 3.5.1 was included Windows 7.

.Net 4.5 was included in Windows 8, Windows 2012, Windows 2012R2.

.Net 4.6 is included on Windows 10.

More info (and any mistranslated/quoted data) at https://blogs.msdn.microsoft.com/astebner/2007/03/14/mailbag-what-version-of-the-net-framework-is-included-in-what-version-of-the-os/

 

It may be that you're using a newer OS, so moving up to 3.5 requires installing an older framework than you already have. Whereas the even older one may have been present from installing other programs that used it already.

 

Yeah, definitely a newer OS.

 

My home computer can run Pine's 2.22 just fine--it didn't even ask me about .NET 3.5, despite it running Windows 10 and me never explicitly installing it--but trying to run it on my work computer (which also runs Windows 10) seems to require .NET 3.5, and I don't have the admin permissions to install it. For now I'm just using version 2.21, which for some reason works just fine and doesn't ask for .NET 3.5, but that means I sometimes run into builds I can't open/import. It's not a huge deal, since I only really screw around with it on my lunch break, but I was curious why the previous version runs fine but the newer one doesn't.

Share this post


Link to post
Share on other sites

Is there a specific thread for reporting data problems in Pine's, or would this thread be it? The Containment feature for the Controller AT is completely off, and as I recall it worked fine in the latest version of Mids.

Share this post


Link to post
Share on other sites

Is there any chance that you could make a App for this builder?


Playing CoX is it’s own reward

Share this post


Link to post
Share on other sites
Is there any chance that you could make a App for this builder?

 

An App?  Why not a HTML5 web page that we can link to?


IifneyR.gif

Verbogeny is one of many pleasurettes afforded a creatific thinkerizer.

Share this post


Link to post
Share on other sites

Is there any chance that you could make a App for this builder?

 

Is there any chance that you could make a App for this builder?

 

An App?  Why not a HTML5 web page that we can link to?

 

I, personally would love to make it html, however, there's a lot of ground to cover in the code before porting would be viable. At the very first chance I get, I'm making this thing a webapp, (and if somehow I manage, it will be mobile friendly)

Share this post


Link to post
Share on other sites

Since it is C# code, porting it to a dot net core web app would be the most appropriate way.

 

Blazor app would be very cool, but obviously there is a ton of UI work that would have to be done to make it viable, but at least all the calculations and such would be ported over.

Share this post


Link to post
Share on other sites

New beta release up, asking Pine to come and talk about what went in, MM /Kinetics now works for me. https://github.com/ImaginaryDevelopment/imaginary-hero-designer/releases

 

I've got a problem where I can't slot Superior Sentinel's Ward in my tier 2 primary power after slotting Superior Opportunity Strikes in my tier 1 primary power.  I did not have this problem with version 2.21 or 2.22.

 

The error message is:

 

Can't Slot Enhancement

"Superior Sentinel's Ward: Accuracy/Damage is mutually exclusive with enhancements in the ArchetypeA group.  You can only slot one member of this group across your entire build."

 


@Rathstar

Energy/Energy Blaster (50+3) on Everlasting

Energy/Temporal Blaster (50+3) on Excelsior

Energy/Willpower Sentinel (50+3) on Indomitable

Energy/Energy Sentinel (50+1) on Torchbearer

Share this post


Link to post
Share on other sites

So if you take Staff Fighting & Bio Armor I noticed that down below where the usual Stamina is it will show the Combos, and below that it will show the Bio Armor toggles, but if you mouse over them, they will instead be the Staff Fighting Toggles.  And you can not turn any of those toggles on.  :-\

Share this post


Link to post
Share on other sites

+inf for your hard work. Build planning would have been a pain if you didnt do all this. :)

Share this post


Link to post
Share on other sites

Having issues importing data chunks as well.

Would you be so kind as to describe the issue?

Pine's v2.22 (have not tested the beta update) simply does nothing when you try to import a build (where "build" is a data chunk copied to the clipboard). This applies even to data chunks produced in v2.22.

Share this post


Link to post
Share on other sites
Guest
This topic is now closed to further replies.

×
×
  • Create New...