Jump to content

Gamepad Trigger Modifier Issue


Recommended Posts

Let me begin by expressing my gratitude for the i27 changes that expanded gamepad support!  However, I am experiencing some awkward behavior with my gamepad, and I would appreciate any assistance that people can spare.


Summary: my Left Trigger is modifying appropriately but my Right Trigger is not


Hardware: Microsoft 360 Controller (wired)

Slash Commands:

Extra modifier 1: Left Bumper
Extra modifier 2: Right Bumper
Extra modifier 3: Nothing
Extra modifier 4: Nothing

Controller Modifier 1: Left Trigger
Controller Modifier 2: Right Trigger

Sample Binds:

Jump: A Button

Alt Tray Toggle: Left Trigger

Alt2 Tray Toggle: Right Trigger

Alt Tray Slot 10: Left Trigger + A Button

Alt2 Tray Slot 10: Right Trigger + A Button

Corresponding Lines from keybinds.txt:

JOY1 "+up"

JOY7 "+alttray"
JOY8 "+alt2tray"

JOYMOD1+JOY1 "powexec_altslot 10"
JOYMOD2+JOY1 "powexec_alt2slot 10"


LTrigger+A is executing as intended, but RTrigger+A is not.  Hitting LTrigger+A summons the Alt Tray and executes the power in position 10.  Hitting RTrigger+A summons the Alt2 Tray and jumps.


I have no idea why these two combinations, which are set up to function identically, have different behaviors.  Here is a short list of things I have already tried.  


Q: "Are the Tray Toggles working?"

A: Yes.  Both triggers call up their alternate trays as appropriate.  Hitting LTrigger+A summons the Alt Tray and executes the power in position 10.  Hitting RTrigger+A summons the Alt2 Tray and jumps.


Q: "Does it work if you unbind A from jumping?"

A: No.  Then hitting RTrigger+A summons the Alt2 Tray and nothing else happens.


Q: "Are you sure you have the power in the correct tray/slot?"

A: Yes.  The default command to execute the power in Alt2 Tray Slot 10, Control+0, still functions.


Q: "Maybe your Right Trigger is broken?"

A: No.  When I press both triggers it puts me into Virtual Mouse Mode as intended.  (It also functions in other games, so I don't believe this is a hardware issue.)


Q: "Is there any other difference between the two Triggers in your binds?"

A: No.  Each occurrence of JOYMOD1 in keybinds.txt has a matching assignment to JOYMOD2, and vice-versa.  Similarly, there is only one assignment each for JOY7 and JOY8.



Writing out my problem in detail has failed to produce any rubber-duck-style epiphanies, so I am desperate for help!





Q: "Can you assign other modified commands to execute that power?"

A: Yes.  I am able to successfully map RBumper+A to Alt2 Tray Slot 10.  However, this does not fix my issue of having a modifier that won't modify.

Edited by divbyn
New Failures
Link to comment
Share on other sites

Here's a functional work-around:


  • Use "/controller_modifiers 7 7" to remove RTrigger from being a controller modifier.  
    • This will change all references to "Right Trigger" in the in-game bind display to "Left Trigger" instead.
  • Use "/extra_modifiers LBumper RBumper RTrigger" to make RTrigger an extra modifier.
  • Rebind everything that used to be based on Right Trigger, but is now using Left Trigger, to once again use Right Trigger.  
    • Be thorough, as you will have to go through this process every time you want Right Trigger to modify anything.
  • Save to keybinds.txt
  • Open keybinds.txt and note that what used to be 'JOYMOD2+JOY1 "powexec_alt2slot 10"' is now 'EXTRAMOD3+JOY1 "powexec_alt2slot 10"'
  • Use "/controller_modifiers 7 8" to once again make RTrigger a controller modifier.
    • This enables Virtual Mouse Mode.


Apparently the issue is that my RTrigger, for some unknown reason, does not want to behave as JOYMOD2 but would be happy to function as EXTRAMOD3.  If anyone could explain why my modifiers are being picky, I would be extremely grateful.

Link to comment
Share on other sites

  • 1 year later

Sorry to necro a post, but I just started working with controller setup and I'm having this exact same problem. Unfortunately, the workaround does not work for me, so I'm stuck with right trigger not working as a modifier. 

I'm using the same hardware (Microsoft XBox 360 controller, wired). 

As a strange twist, the problem happened just today. The trigger worked as a modifier last night when I first set it up, but now doesn't work at all. I turned off the game, turned it back on, I noticed my binds disappeared so I loaded them from the file, and the right trigger isn't working.

The Keymapping tab of the options window does seem to recognize it as a modifier (for example, the Alt2 Tray Slot 1 is set as "Right Trigger+X Button), but when I press it, it doesn't fire.

Does anybody have any suggestions about how to fix this?

Link to comment
Share on other sites


  • Create New...