Jump to content

Map Waypoint locked to inaccessible contact


Completist
 Share

Recommended Posts

Here's a fun one. 

As a level 20 Praetorian, who has not yet completed the arc to leave Praetoria, I tried to use the "Find Contact" feature to teleport to a contact in Talos Island. Namely, Mistress Eva. The game tried to load Talos then bumped me back to Imperial City like it's supposed to.

 

Now, Mistress Eva is the selected contact. If I create a map waypoint, or click a different contact in the contacts menu, or select a mission, it switches back to Mistress Eva after a sort delay. This persisted even after I restarted the game days later.

 

Even more fun: I figured out how to change my target by selecting a mission and then very quickly pressing the "select task" button. But now that task behaves in the same way as Mistress Eva waypoint did: if I place a waypoint or click a different mission/contact, the waypoint jumps back to it after a short delay. 

 

When I log out and log back in, Mistress Eva becomes my waypoint again. 

 

Completing Dr. Steven Sheridan's arc to become a Hero (and entering Talos Island) resolved the navigation issue. 

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
×
  • Create New...