Jump to content

Macro's keep half wiping


Recommended Posts

I have a simple macro set up to return me to human form from White Dwarf, and change the power tray to tray 1:


goto_tray 1$$powexec_toggleoff White Dwarf


However, every time I change instances (i.e. enter / exit a mission or change map, etc), it resets the macro to just read:


goto_tray 1


So I have to edit the macro every time I change instances to change it back to what it should be. This is infuriating! Weirdly, I also have a macro set to go to tray 3 and activate White Dwarf, and that one is absolutely fine.


Anyone know a fix? tried using different tray numbers, and exiting, re-entering the game to no avail.



Link to comment
Share on other sites

I haven't played a Kheld on Homecoming, but I (somehow) still had my bind files from the old days. The only thing that I notice different is that I have them in the reverse order.


My "Human" macro looked like this:  /macro H "powexectoggleoff bright nova$$powexectoggleoff white dwarf$$gototray 1"


Are you including the quote marks when you create it?  That could be the issue.


  • Thanks 1
Link to comment
Share on other sites

Thanks Hardship, that appears to have worked! It appears I had to indeed swap the macro's around. So this seems to work (at least so far):


powexectoggleoff White Dwarf$$goto_tray 1


The quote marks didn't seem to make any difference.


Thanks again!



Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
  • Create New...