Jump to content

Bug in Auction House with placing orders to buy or sell


Recommended Posts

I have now ran into this bug enough times to realize it is not a one time thing, but not enough to be able to figure out how to fully force it to happen on command. It still has happened enough times that I have begun to suspect what might be occurring but I will leave it to others to figure out if my speculation is correct.


Anyway, I /petition reported it and was asked by the responding support GM to post the bug here on the forums as well. I meant to do so sooner but did not have a chance before now.


Basically the bug is that instead of sending the buy or sell order once, it constantly nonstop sends the code when the bug triggers. This can result in dozens or hundreds of duplicate buy orders, or in the reverse case dozens of attempts to sell items that were in your storage. Eventually the code hits the spam limit and starts to send back messages about the auction house being busy and unable to handle the order.


The first time I ran into this bug I ended up purchasing 73 units of salvage at an inflated price when I was only trying to purchase 6 total. Luckily I was able to cancel the rest of the 136 copies of the order before it bought the salvage.


The second time I ran into this bug it attempted to purchase several copies of the exact same enhancement at several million inf each. Luckily the character I was on at the time only had enough money on hand to purchase a few copies of it.


The third time I ran into this bug it placed a dozen enhancements from my stored to my selling tabs - luckily I planned on selling them anyway.


The fourth time it again tried to create dozens of salvage purchase attempts but this time the duplication was for a bid of just 1 inf each so they clogged up my AH slots without actually purchasing anything and it only took a few seconds to clean up all the entries.


The actual bug is based on the selected listed AH object in the upper right list of the AH. Occasionally it gets bugged, no clue how, and if I left click on a specific spot in that entry it instead sends endless duplicate attempts of whatever was the last thing I sent to the AH code before clicking there. It is like an endless "back step, enter, back step, enter" loop happens.


If it helps I am running the Tequilla version of the 64 client, and so far it has only happened while I had 2 copies of the client opened but one of them logged out and sitting in the account login screen.

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
  • Create New...