Jump to content

Issues opening Island Rum


Recommended Posts

I'm having issues opening Island Rum to get into COH. I recently updated my Mac using the Open Patch method to run OS 13.3.1 Ventura. When I open Island Rum I get a black screen in the Island Rum window. I've attached a screen shot of the screen. My mac configurations are Late 2013 iMac 27" with i7 and 32 GB ram. Any clues as to what I can do to try to fix this? Any advice is appreciated. Please includes steps on how to fix.



As a update I tried to reinstall COH and I get a message that it cannot be installed and needs to be updated by the developer.




Screenshot 2023-04-08 at 9.36.14 PM.png

Screenshot 2023-04-08 at 10.11.54 PM.png

Edited by Mellomike
Link to comment
Share on other sites

Same here, same error message (this indicates a certificate problem).

There are some other threads on this Mac topic, with different launchers to install from Manga.

None of them work for me, the certificates are screwed up.

I'm on Ventura 13.3.1 (latest).

Link to comment
Share on other sites

I figured out that in order to run the installer in Ventura OS you have to go into the System Settings > Privacy & Security and give the permission to open the installer. Signing into COH using the patch is different now compared to using Island Rum but I like it.

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
  • Create New...