Jump to content

Repeated freezing and crashing, on newer machine...

Recommended Posts

Haven't been able to narrow down where or when it happens... Sometimes in TOT madness, sometimes in solo missions.


If it offers a chance, I submit a report, but sometimes it just freezes and closes. Once it even blue screened the whole box.


My PC is brand new, just upgraded it a couple months ago:


AMD Ryzen 9 7900X3D 
32 GB Ram

Win 11 (22621 build)

AMD Radeon RX 7900 XTX (Driver version 31.0.22011.4008)

Brand new SSD 2TB M2 drive...

Not sure what other specs really matter... 


Tried GFX reset, turned that off after a while as it got annoying to re-set it every time I launched. Verified game files, no issues. Temps are fine, even when game is going full bore: CPU and video hovers at about 50c...

Link to comment
Share on other sites

Try /graphfps 7 (/graphfps 0 to shut off) and see if one component over the others is causing a bottleneck or halting the game.  (It'll cover your right half of the screen with a transparent graph. Teams and TOT league may fare better over TF and iTrials in trying to make it crash on purpose.)  Swap is your HDD chart, with CPU and GPU self-explanatory.

I doubt network is causing crashes, but that's a separate graph: /netgraph 1 (/netgraph 0 to shut it off.)

  • Thanks 1

I am not a chat bot, I think.  I just drink a lot of caffeine and type too damn much.

Link to comment
Share on other sites

Have you tried using the "-usetexenvcombine" launch parameter...It may help.


You will find this in the Homecoming Launcher, click the 3 dots next to Ready, then click settings, enter the parameter in the Launch Parameter field.

It will use this each time you load with no further effort.

Also I have heard there are issues with the way graphics suites try to run the game and it may require using a basic driver.

COH is old and requires OpenGL , newer cards may not natively support that.

Edited by Marine X

" When it's too tough for everyone else,

it's just right for me..."

( Unless it's Raining, or Cold, or Really Dirty

or there are Sappers, Man I hate those Guys...)

                                                      Marine X

Link to comment
Share on other sites

Thanks for the assistance, everyone! I finally seem to have it fixed (watch it start breaking again lol)


I'd verified files several times, but about the 10th time I did so, it complained that 1 pigg was corrupt. I deleted it, redownloaded it, and verify showed another bad pigg. Then, I deleted ALL the piggs, redownloaded them AGAIN, and machine blue screened. Each time I opened the launcher, my machine froze. I deleted 1 pigg that was 0 bytes, and launcher allowed me to re-download, again. Been good for several days, now 🙂


Short version: Re-verify files  more than once. 🙂

  • Thumbs Up 2
Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Create New...