Jump to content

Stance issue when zoning


Recommended Posts

  • Homecoming Team

Follow these steps:

  1. Set your inherent stance to Ninja
  2. Activate Beast Run
  3. Zone (in my test I went from Atlas to The Hollow)
  4. Disable Beast Run
  5. Beast Run buff icon is still visible despite the power being deactivated
  6. Inherent Ninja stance is suppressed by the fake Beast Run

Got time to spare? Want to see Homecoming thrive? Consider volunteering as a Game Master!

Link to comment
Share on other sites


  • Create New...