Jump to content

popmenus are broken


Recommended Posts

I have quite a number of menus defined for my install, both long pick-lists of predefined chat messages in the appropriate language for characters with foreign backgrounds and short power-option menus for location AoE powers (letting me use the power normally, target it straight down — below me if I'm flying, or at my feet if I'm on the ground — or centered under my current target). I'm not experiencing any problem with any of them.


My first question is, do you have the game client open when you save your new .mnu file? The client loads the .mnu files when it starts up; any changes or new files will not be usable until you restart your client.


Second question, are you saving the files with a .mnu extension and in the 'data\texts\english\menus\' folder of your client install? One common mistake is to forget that Windows, by default, hides file extensions in the File Explorer and in file open/save dialog windows, so if you think you're saving a file as 'newmenu.mnu', you may actually be saving it as 'newmenu.mnu.txt', which the game client won't recognize as a menu file. In a File Explorer window open to the menus folder, select the 'View' tab of the ribbon, and check 'File name extensions' if it is not already checked, and make sure your files have the correct extension.

Link to comment
Share on other sites

Well, this is lame.   So, I copied your menu and it didn't work as described.  When I looked at my launcher log, it complained

ERRORLOG FILEERROR: texts/English/menus/test.mnu
File: texts/English/menus/test.mnu
Parser: unrecognized token xxchat in texts/English/menus/test.mnu, line 1

Putting an empty line as line one, solved it.

Menu "xxchat"
   Title chat
   Option "help chat &q" "beginchat /hc [@Lemming] "
   Option "LFG &z" "beginchat /lfg [$level $archetype] "
   Option X "say This seems to work now"


So, bit of an odd parser error, but it works now.   Missed it because all my menus have a bit of documentation which had the whitespace in there.   On the plus side, looking at the log showed another one of my commands had an error. 😉 


  • Like 1
Link to comment
Share on other sites


  • Create New...