Jump to content

Blaster - Temp Manip - Temporal Mending


Recommended Posts

Many of this power's feature stop working for no apparent reason.  I tried this on both a new toon created on Brainstorm and one transferred over from Indomitable.  In the first case the power was functioning on log in but stopped within 2 seconds after log in.  This was repeated with a log cycle.  Re-toggling the power seemed to fix the issue.  Then I used the Tunnel system to go from AP to Talos and the power stopped working properly about 1 second after zoning.  I then transferred and tried the second toon.  Her power worked fine until I re-toggled it.  The Absorb shield came on, but none of the other effects were applied.

The first screenshot shows the toggle on in the power tray (bottom right, slot 1 of tray 3), the status bar (top right, the right-most icon) and the graphics (the floating Absorb and pale white swirl graphics).  Yet there are no Regen Res, Recharge Time Res buffs and the Recovery rate is just base+unslotted Stamina.  This can be seen in the Combat Attributes monitor in the upper right region.  The second screenshot shows what it looks like after re-toggling and is working properly.



Edited by csr
Link to comment
Share on other sites

  • 3 weeks later
  • Developer

Verified Working. This appears to be working correctly on the latest build on Brainstorm or I'm unable to reproduce; Unable to get it to stop applying through a couple of logouts and zone changes.


time manip.PNG

Love this game and its community? Want to give back? Volunteer as a Game Master! Help make Homecoming the best it can be!

Writer of the Patch Notes

Red side, best side!

Link to comment
Share on other sites

  • Jimmy locked this topic
This topic is now closed to further replies.
  • Create New...