Jump to content

Deadlock's Personal Story


Recommended Posts

Now I'm not sure how this works on the Live servers.

I still had this mission after having boosted my level to 40.

Back Alley Brawler spawned as an Elite Boss who absolutely destroyed me, that seemed like probably just an unfortunate side effect of running it at 40. The Longbow in the mission were Grays, I didn't look closely but I assume they were probably like level 18 or something. BaBs was scaled to my level. However...


What was clearly a Bug was that when it said "Use the Serum Now" No Serum Appeared.

The mission seems to be broken, at least if you keep it until high level. I tried it on a level 17 character and the Serum appeared in my tray as normal.

Link to comment
Share on other sites

  • Developer

Verified everything in this post; Created a new character; Leveled to 18; Completed Eagle Eye's mission arc; Grabbed the Personal Story; Leveled to 40; Went into mission.

-Longbow Level 18.
-BaBs killed me in one-two hits doing all my health even with Strength of Will up and con'd properly to my level.
-No serum appeared.

Re-zoning had me take the mission again each-time but it was locked at level 18. Screenshot below should verify all details:


Edited by Nayreia / Karonax
updated screenshot including power bar for no serum
  • Thanks 1

Love this game and its community? Want to give back? Volunteer as a Game Master! Help make Homecoming the best it can be!

Storyteller & Writer of the Patch Notes: Red side, best side!




Link to comment
Share on other sites

Tried picking up the mission at level 7 (it shouldn't be possible to access this mission at any lower level), then messing with my xp level to simulate different levels before going in.

  • This worked at levels 7, 8 & 9 just fine.
  • Levels 10, 11, 12 & 20 didn't work.
  • Setting difficulty to +4 and level 13 worked, since this changes the mission level to 11 once on the map.
  • Difficulty +4 at level 14 did not grant the serum.
  • Difficulty +4 at level 7 worked.
  • Difficulty -1 (lv. 6) at level 9 did not grant the serum.

So it looks like if you're more than two levels higher than the mission, the Serum isn't granted to the player.

Edited by Molubdos
Extra testing
  • Like 1
  • Thanks 2
Link to comment
Share on other sites


  • Create New...