Jump to content

Active Build 2 and 3 have no powers available

Recommended Posts

Created a new 50 Stone/Rad Tanker on Beta to experiment with builds and when I switched my active build to #2 and tried to train up, I had no powers available. Not greyed out, just not there. Blank. Tried the same thing changing to active build 3 and same result.


Also, clicking "Powers" on my tray brought up blank Primary and Secondary rows as well. Again, not greyed out powers. They just weren't there.


This was all with Miss Liberty in Atlas Park.

Link to comment
Share on other sites

  • 2 weeks later

Have you already trained up to 50 on the primary build? 

Sorry in advance if that's a dumb question been awhile since I've been able to get online (outside of this phone) and haven't been on test since Live.  The extra builds afaik don't normally unlock until you are actually a trained lvl 10+ and 50+.  Might not start showing up until you've leveled your primary build to 10 is what I'm wondering.

Link to comment
Share on other sites

They won't have the option IIRC before 10 anyway.

Hopped on test -

Jump to level 10, train level 2, no option for a "second build." (which is not what's being described as missing, anyway.)

Leveled to 10. Second build becomes available.

Went in to level up second build (to see if it happens right away or not) - got what's in the screenshot. So, yeah. THat's an issue. However, logging off (to character select) and back on, while still on the second (empty) build, brought the power selections back up.


Going back to the first build had no problems.

Waiting, then selecting build 2 (still unleveled at that point) came up fine afterward.



Further testing -

First test was on a bio/bs tank. (Magic origin, staying as consistent there as possible.) Got the empty screen.


Second test, ar/dev blaster, did not do the same thing at level 10 when going to the second build.


Third test, bio/dark tank - same thing. Blank leveling screen at level 10 when going to create a second build. (picking only primary/secondary, since that's what I did with the blaster, first bio tank had a power pool as well.)


Fourth test - bs/bio brute. Same thing when going to the second build.


Edit: Checked my 13 katana/bio scrapper on live. Didn't have this issue.


So, if anyone else wants to test - check anything with bio armor, only have to level the first build to 10 to check. If you want to check other powersets (other armors, maybe,) on test - from what I see so far this is just bio armor, and only if you level and try a second build right away without restarting / going back to logon.



No Powers.JPG

Edited by Greycat
  • Like 1

Primarily on Everlasting. Squid afficionado. Former creator of Copypastas. General smartalec.


I tried to combine Circle and DE, but all I got were garden variety evil mages.

Link to comment
Share on other sites

  • Create New...