Jump to content

Game "Not Responding" when loading into a city zone (after switching to a new GPU)


Recommended Posts

I have just switched to a new graphics card (from Geforce 980ti to Radeon 7900XTX, on Windows 10).

Uninstalled old drivers and Nvidia software, installed AMD Adrenaline drivers from the official website.

Unfortunately, I can no longer load into a city zone anymore.


I can log in to the client and create or select a hero normally. (So at least rendering 3d characters is ok.)

After selecting a character to jump into the game world, the zone loads, ambient sound effects start playing and then the loading screen remains frozen.

Waiting for anything to happen ultimately ends with "Client not responding".


I have tried a number of other games, and sadly CoH is the only one where I hit a wall. 😕

I have tried looking for similar issues via search but have not caught one just like this.

Please let me know if you have encountered something like this (and hopefully fixed it too 🙂 ).

Link to comment
Share on other sites

IDK enough about the cards to give you too much direction, but it sounds like Maybe the newer card is having issues with the OpenGL that CoX is coded for. You Could try resetting the graphics in the launcher on your next startup and see if that has an impact.


Resetting Graphics:

  1. With the Launcher open, click the three dots below the start button for the game version you're trying to launch
  2. A context menu will open up, choose "Settings"
  3. The settings will open to That game version's tab
  4. Click to put a check in the box labelled "Reset graphics settings on next run"
  5. Load the game and test it out

Now what I don't know is if that box will remove the check on the following launch or not, so you may want to go check it after doing it once.

  • Thumbs Up 1

OG Server: Pinnacle  <||>  Current Primary Server: Torchbearer  ||  Also found on the others if desired

Installing CoX:  Windows  ||  MacOS  ||  MacOS for M1  <||>  Migrating Data from an Older Installation

Clubs: Mid's Hero Designer  ||  PC Builders  ||  HC Wiki  ||  Jerk Hackers

Old Forums  <||>  Titan Network  <||>  Heroica! (by @Shenanigunner)


Link to comment
Share on other sites

Thanks for the tip!

That allowed me to get back into the game.


I tried turning different options back on, one by one.

Setting Shadows to anything other than the default setting causes the game to reload assets (maybe?) and that reload somehow locks up.

  • Like 1
Link to comment
Share on other sites


  • Create New...